NC:remote not updated when remote location added in.

RESOLVED INVALID

Status

Calendar
General
RESOLVED INVALID
14 years ago
13 years ago

People

(Reporter: Mark Proctor, Assigned: Mostafa Hosseini)

Tracking

Details

Attachments

(4 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a3) Gecko/20040817
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a3) Gecko/20040817

I have 6 calendars setup and all on webdav. When I refresh only four of them
actually get updated from the remote source. Currently I have to remove and
re-add the calendar to get the updated information.

Reproducible: Always
Steps to Reproduce:
(Reporter)

Comment 1

14 years ago
Here you can see it updates:
mproctor.ics
darielleandmark.ics
Dutch_Holidays_2002-2005.ics
Public32Holidays.ics
but not dbedding.ics or mim.ics

console output:
RemoveCalendar in calendarManager.js: button is 0entering getNode

CALENDAR unifinder.js->on selection changed
--->>>>unifinder.js selection callback :: Clear selection
 Changing old value in urn:calendarcontainer:calendar6


RemoveCalendar in calendarManager.js: button is 2init channel,
Channel is [xpconnect wrapped nsIChannel]
URL is http://svn.xxx.net/calendars/mproctor.ics

 calendarManager-> remove calendar D:\Documents and Settings\mproctor\Applicatio
n Data\Mozilla\Profiles\default\x5mb2n8l.slt\Calendar\CalendarDataFile1.ics
CALENDAR unifinder.js->on selection changed
--->>>>unifinder.js selection callback :: Clear selectioninit channel,
Channel is [xpconnect wrapped nsIChannel]
URL is http://svn.xxx.net/calendars/darielleandmark.ics

 calendarManager-> remove calendar D:\Documents and Settings\mproctor\Applicatio
n Data\Mozilla\Profiles\default\x5mb2n8l.slt\Calendar\CalendarDataFile3.ics
CALENDAR unifinder.js->on selection changed
--->>>>unifinder.js selection callback :: Clear selectioninit channel,
Channel is [xpconnect wrapped nsIChannel]
URL is http://www.mozilla.org/projects/calendar/caldata/Dutch_Holidays_2002-2005
.ics

 calendarManager-> remove calendar D:\Documents and Settings\mproctor\Applicatio
n Data\Mozilla\Profiles\default\x5mb2n8l.slt\Calendar\CalendarDataFile4.ics
CALENDAR unifinder.js->on selection changed
--->>>>unifinder.js selection callback :: Clear selectioninit channel,
Channel is [xpconnect wrapped nsIChannel]
URL is http://icalx.com/public/elc/Public32Holidays.ics

 calendarManager-> remove calendar D:\Documents and Settings\mproctor\Applicatio
n Data\Mozilla\Profiles\default\x5mb2n8l.slt\Calendar\CalendarDataFile6.ics
CALENDAR unifinder.js->on selection changed
--->>>>unifinder.js selection callback :: Clear selection
(Reporter)

Comment 2

14 years ago
Created attachment 157392 [details]
dbedding edit properties
(Reporter)

Comment 3

14 years ago
Created attachment 157393 [details]
mim edit properties
(Reporter)

Comment 4

14 years ago
Created attachment 157394 [details]
mproctor edit properties
(Reporter)

Comment 5

14 years ago
Created attachment 157395 [details]
calendar
(Reporter)

Comment 6

14 years ago
ok I found the issue. Despite me adding an entry for "remote location" the
following was still false:
NC:remote="false"

I change it to "true" and it worked. I think if you specify a remote location
NC:remote should automatically be set to "true" - or atleast another tickbox to
specify the calendar is remote.

Comment 7

14 years ago
Not confirming, but am fixing summary
Summary: not all calendars refresh from remote ics file on webdav, even though they have remote locations set → NC:remote not updated when remote location added in.

Comment 8

13 years ago
This looks closely related to bug 217197, especially when comparing summaries. 
Reporter, can you take a look at that bug and say whether or not you think it
describes the same issue?

Updated

13 years ago
QA Contact: gurganbl → general

Comment 9

13 years ago
Based on the short-description, this is INVALID, since we don't store this data in rdf format anymore.  Alternatively, see previous comment for a likely duplicate.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.