If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

NatWest DHTML menus broken since v0.9.3 for OS X (working on v.0.9.2)

RESOLVED EXPIRED

Status

()

Firefox
General
RESOLVED EXPIRED
13 years ago
12 years ago

People

(Reporter: Ian McCall, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/125.4 (KHTML, like Gecko) Safari/125.9
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

If you log into this online banking site, the DHTML menus are now broken. These previously worked on 
Firefox v0.9.2 for OS X, and they also continue to work for v0.9.3 on Windows (haven't tried Linux).

Reproducible: Always
Steps to Reproduce:
1. Log in to http://www.nwolb.com (requires a NatWest acccount)
2. Try to select a menu item from the left-hand side
Actual Results:  
Overall menu changes, but no menu items appear and no selection can be made.

Expected Results:  
Menu should expand into a list of available menu items, as per v0.9.2 on OS and v0.9.3 on Windows.

This is one of the big four banks in the UK, and they recently changed their site to make it Mozilla-
friendly. See http://bugzilla.mozilla.org/show_bug.cgi?id=66911 for more details (and a possible 
contact if necessary).
(Reporter)

Comment 1

13 years ago
Just tried again on 1.0PR - still broken on the Mac. Works with the same Firefox
version under W2K and WinXP.

Comment 2

13 years ago
The DHTML menus are selected when nwolb.com thinks that your browser is IE. They
have another version for Netscape 4.7 (but not v4.8).

They have added the mozilla user-agent string to their list of approved browers
and it should redirect to the NS 4.7 version (which lacks dynamic menus). Try
changing your useragent string, either to mozilla (on windows / linux ?), or try
changing it to NS 4.7.

Comment 3

13 years ago
Can  you please check the Javascript console and see what errors you get?
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.