If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

royalbank.com - Can't paste numeric text into some online forms

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English Other
RESOLVED FIXED
13 years ago
2 years ago

People

(Reporter: John C Gilmour, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

When attempting to log into my online banking site, I am unable to paste account
number information into the specified field.
This only occurs on one of my banking sites (URL specified above)

Good Luck,  Thanks, John

Reproducible: Always
Steps to Reproduce:
1. goto
https://www1.royalbank.com/cgi-bin/rbaccess/rbunxcgi?F6=1&F7=IB&F21=IB&F22=IB&REQUEST=ClientSignin&LANGUAGE=ENGLISH
2. attempt to paste any number into the account number field
3. No paste occurs.

Actual Results:  
Nothing

Expected Results:  
incerted the copied number.
Pasting works fine using the menuitem.  It doesn't work with Control-C, however
(it would have been nice to clearly say how you were pasting).

The reason Control-C does not work is that the web site explicitly cancels most
keypress events for that text input (note that Control-X doesn't work to cut,
you can't type letters in the textbox, and so forth).

Over to evangelism; Mozilla is doing exactly what it should be given the JS on
that site.
Assignee: general → english-other
Component: Browser-General → English Other
Product: Browser → Tech Evangelism
QA Contact: general → english-other
Version: Trunk → unspecified
(Reporter)

Comment 2

13 years ago
Using CTRL-V for paste works in all cases when using IE.
If Firefox is to take the world, It will have to do all and then better it!

Thanks for your input.

John
> Using CTRL-V for paste works in all cases when using IE.

Two things:

1)  The page runs very different JS in Firefox and IE.  I didn't bother digging
    into the exact differences in their event processing code for the two.
2)  Given the code that _is_ run in Firefox, its behavior is correct.  If the IE
    code is equivalent and IE does something different, that's a bug in IE.

"Taking the world" shouldn't mean creating an identical clone of IE, including
all possible bugs.

Updated

13 years ago
Summary: Can't paste numeric text into some online forms → royalbank.com - Can't paste numeric text into some online forms

Updated

10 years ago
Blocks: 124594
Works for me -  SeaMonkey 1.1.9 (linux).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.