If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

cursor:auto doesn't lead to pointer cursor for A element

RESOLVED DUPLICATE of bug 88688

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 88688
13 years ago
13 years ago

People

(Reporter: Adam Hauner, Assigned: dbaron)

Tracking

({testcase})

Trunk
x86
Windows 2000
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
2004082909/SeaMonkey-trunk/W2K

When "cursor" property is set to "auto" value for A element, it doesn't results
to "pointer" (hand) cursor. I'm not sure, what is right behavior in this case,
but regarding CSS 2.1 spec it looks that Mozilla has bug.

http://www.w3.org/TR/CSS21/ui.html#propdef-cursor
auto
    The UA determines the cursor to display based on the current context.

Ian: Maybe specification should contain some example for "auto" value or
additional clarification. 

BTW: Opera 7.60 PR 1 will display "hand" cursor above A element in attached
testcase.
(Reporter)

Comment 1

13 years ago
Created attachment 157473 [details]
testcase

*** This bug has been marked as a duplicate of 88688 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.