Closed Bug 25751 Opened 21 years ago Closed 20 years ago

wrong real window size when maximize

Categories

(Core :: XUL, defect, P3, major)

x86
Linux
defect

Tracking

()

RESOLVED WORKSFORME
Future

People

(Reporter: pasky, Assigned: pavlov)

References

()

Details

(Keywords: platform-parity, Whiteboard: Needs testing on Linux)

Attachments

(1 file)

When I open a link in new window from maximized one, new one opens maximized
too, but interior is smaller, the rest of window is filled by gray. At URL,
screenshot is available...
This works properly on Windows NT 4.0sp3 with 2000-01-28-12-M14 ...
it needs to be tested on Linux, with more than one Window Manager.

pasky@pruvodce.cz, what build did you use? Please say M13 if it was, or
give the Build ID of a nightly binary. Also, please specify the Window Manager 
you were using. Also, from here, I have not been able to view the gif at the 
URL: NN 4.7 reports "unable to locate server". Please check your typing,
and if it is correct, use the "Create a new attachment" link above to attach
the gif directly to this bug report. Thanks!
Whiteboard: Needs testing on Linux
Assigning all open "nobody@mozilla.org" bugs to "leger@netscape.com" to weed 
thru.
Assignee: nobody → leger
can not reproduce on win98, moving to XPApps.
Component: Browser-General → XPApps
I'm sorry for the wait... This bug unfortunately doesn't happen every time, but 
only in several conditions, I haven't explored them yet :(
Shrir, do you see this with today build?
Assignee: leger → trudelle
Component: XPApps → XP Toolkit/Widgets
QA Contact: nobody → paulmac
resolving as wfm. If you still see it, please reopen with sufficient information
to reproduce.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
*** Bug 28379 has been marked as a duplicate of this bug. ***
*** Bug 30414 has been marked as a duplicate of this bug. ***
Reopen bug
Status: RESOLVED → REOPENED
Keywords: pp
Resolution: WORKSFORME → ---
Note: this is a linux only bug.

Here are some comments from the duplicate bugs which should assist in reproducing 
the bug:

#28379 submitted by tshanno@luc.edu
Open a html file in the composer/editor.  In my case, it was the my bookmark
file (.mozilla/profiledirectory/bookmark.html).  Maximize the window.  The
window maximizes but the page doesn't and stays small within the window.

#30414 submitted by eparis@andrew.cmu.edu
To reproduce:

1) rm -Rf .mozilla
2) Start mozilla
3) Create new profile
4) After mozilla finishes displaying the home page, click on the maximize button
of the mozilla window.
5) The window will maximize but the displayed home page will remain the same
size as before.

This is M14 and my window manager is enlightenment.

After closing mozilla and running it again maximize works with no problems.
After 6 tries, I finally found a document that exhibits the defect desribed in
#28379 submitted by tshanno@luc.edu.
It didn't happen on simpler documents, but the RDF Schema Specification did the
trick.  It wasn't just on maximize though, the same thing happened when I grew
the window size, and in fact once it started happening, it now happen on every
other window too.
reassigning to pavlov as p3 for m15

Assignee: trudelle → pavlov
Status: REOPENED → NEW
Target Milestone: M15
Mass-moving most M15 bugs to M16
Target Milestone: M15 → M16
spam, open xptoolkit qa contact moving over to jrgm
QA Contact: paulmac → jrgm
*** Bug 36779 has been marked as a duplicate of this bug. ***
Moving all bugs that are not dogfood+, nsbeta2+,features, or nsbeta2- to M21
Target Milestone: M16 → M21
Target Milestone: M21 → Future
Unable toreproduce in 12/15 build on linux.  is anyone else still seeing this?
comments from reporter:
I haven't seen this problem in quite a long time. I think it is safe to
close this bug.
Cheers!
El
Ah, yes, this bug. There is a duplicate somewhere. It's been a "hide-and-seek"
bug for some time now. Marking Worksforme, but reopen if/when it reappears (or
actually, should find the duplicate of this bug).
Status: NEW → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.