Closed Bug 257532 Opened 16 years ago Closed 16 years ago

spoofed headers marks fresh email as already read

Categories

(Thunderbird :: General, defect)

x86
Windows 98
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 196749

People

(Reporter: kae, Assigned: mscott)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

I get quite a lot of spam. recently, I've been receiving email which is flagged
as already read.

Reproducible: Always
Steps to Reproduce:
1. go to http://webworks.ie/test.php
2. enter your email address in the box and hit submit
3. check your email

Actual Results:  
I received an email which was marked as already read.

Expected Results:  
I expected an unread email.

The flag for read emails is spoofed in the mail sending thing by sending
"X-Mozilla-Status: 0011" as a header. When I check a fresh email, I see that
there is another X-Mozilla-Status with 0000 as the value, buit that is
overridden by the spoofed one.
  I see this trick used sometimes by spammers.
Which TB version (build number)? Should be fixed, see Bug 196749. Dupe?
(In reply to comment #1)
> Which TB version (build number)? Should be fixed, see Bug 196749. Dupe?

version 0.7.2
pretty recent - 20040707

yes, this looks like a duplicate. sorry.
just checked in most recent (0.7.3 - 20040803) official build. the bug is still
there.
I don't know that the fix went into 0.7.2/3

*** This bug has been marked as a duplicate of 196749 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.