inconsistent keyboard shortcut handling while in text fields

VERIFIED DUPLICATE of bug 257547

Status

()

Firefox
Keyboard Navigation
--
enhancement
VERIFIED DUPLICATE of bug 257547
14 years ago
14 years ago

People

(Reporter: jon moses, Assigned: Aaron Leventhal)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

There is inconsistent shorcut handling while in text field, both application and
html form text fields.

It seems that while the focus is in a text field, the text keyboard shortcuts
take precendence over the application shortcuts.

For example, CTRL+W will delete the last word typed, rather than close the
current tab.

This, I think, is fine in the HTML form fields, but I don't think this is
correct behavior in the application text fields such as Location and Search. 
I'd love to see this be reversed for application text fields, or a hidden
preference created for this.  Or I could be way off base.

Reproducible: Always
Steps to Reproduce:
1. Put focus in location field.
2. CTRL+W


Actual Results:  
Last word type deleted

Expected Results:  
closed tab.
(Reporter)

Comment 1

14 years ago
Wups.  this is my bad.  accidently closed browser window on first bug submittal,
didn't receive any email and couldn't find it via search so I assumed it didn't
process.

*** This bug has been marked as a duplicate of 257547 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.