[BACKGROUND] Rendering problems with transparent background images

VERIFIED WORKSFORME

Status

()

Core
Layout: Tables
P3
major
VERIFIED WORKSFORME
19 years ago
19 years ago

People

(Reporter: Christophe.long, Assigned: karnaze (gone))

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
at the url http://www.webmotion.com/news/index.fr.html the colors of the middle
of the page are wrong ! Sometimes mozilla crashs on this page,  but sometimes it
displays it.

Comment 1

19 years ago
If you mean that the background of the main table appears in black, then this 
is a dup of bug 16100.

The HTML causing the problem is:
TABLE BACKGROUND="../images/1x1-transp.gif"
Component: Browser-General → ImageLib

Comment 2

19 years ago
Sorry, that should have been bug 18170. Changing component again (sorry for the 
spam).
Component: ImageLib → HTMLTables

Comment 3

19 years ago
Assigning all open "nobody@mozilla.org" bugs to "leger@netscape.com" to weed 
thru.
Assignee: nobody → leger

Comment 4

19 years ago
This link no longer exits.  Marking this Invalid for now.  If you have the same 
problem at a differnt page with latest build, let us know.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID

Comment 5

19 years ago
Marking Verified
Status: RESOLVED → VERIFIED

Comment 6

19 years ago
Posted to me by the reporter:
>What do you mean by the link is invalid ? The webpage I sent you is still
>valid... Now it shows correctly the page with
>mozilla-i686-pc-linux-gnu-M14-talkback  but mozilla is almost freezed (it
>reacts very slowly when you move the window or when you try to go down in
>the page)

christophe: it is better to reply to the actual bug rather than in email. As 
you can see, it's taken me ages to get round to reopening this...

Further to the comments posted to me by the reporter I'm going to reopen this 
bug so that it can be resolved some other way becuase the link works for me.

The page initally appears to display correctly but after a long freeze the the 
background of the table turns black. Build 0302108 WinNT 4 SP6.
Status: VERIFIED → REOPENED
Resolution: INVALID → ---
Bug also occurs in build 2000-03-27-18 on NT4 sp6, changing Platform/OS to All.
Keywords: testcase
OS: Linux → All
Hardware: PC → All
Summary: Wrong colors displaying → [BACKGROUND] Rendering problems with transparent background images

Comment 9

19 years ago
That page and the test case work fine for me, using build 2000040908 for Windows
95 and 2000040909 for Linux.
However, it seems the page that started this has changed its html code, at least
I couldn't find a <table background="..."> tag, so I used mats' test case for
validation.
Bug 34838 currently prevents table background images (but not td background
images) from rendering in non 4.0-strict (Nav Quirk) mode, so I created a few
test cases using 4.0-strict mode (with 1x1, 2x2 and 16x16 background images).
They too work fine for me, though the 1x1 images take awfully long to get
rendered, and when the image is completely transparant it may just seem as if
the page freezes for no reason.
Take a look at http://users.bart.nl/~disttsc/bugzilla/bug25757.html showing what
I mentioned above.

Comment 10

19 years ago
Updating QA Contact.
Assignee: leger → karnaze
Status: REOPENED → NEW
QA Contact: nobody → chrisd
(Assignee)

Comment 11

19 years ago
I'm not seeing the problem on the url or test case.
Status: NEW → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → WORKSFORME

Comment 12

19 years ago
Build id: 2000050811 Linux
I agree the orginal point no longer exists (page colours are wrong), but this
page is sucking up 100% power on a Linux machine whenever it loading/being
scrolled so I'm going to reopen it. NS 4 does not drive the CPU load to 100% for
nearly as long when loading the page and barely uses any power when scrolling.
Concerning the test case it seems to load fairly quickly but highlighting text
is very slow and again uses lots of power. Would it be better to open a new bug
for this?
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Comment 13

19 years ago
I just opened bug 38672 and am closing this one. 
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → WORKSFORME

Comment 14

19 years ago
Incorrect colour problem worksforme.
Verified 2000050811 Linux.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.