[DOM] remove event listener (removeEventListener method) fails

VERIFIED FIXED in M18

Status

()

Core
Event Handling
P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: myk, Assigned: joki (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixinhand][nsbeta3+], URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Overview Description: 

The removeEventListener method should remove an event listener created 
with the addEventListener method, but it doesn't.

Steps to Reproduce: 

1) Create an simple event listener function that does something noticable.
2) Register the event listener on the document.
3) Remove the event listener.
4) Trigger the event.

(in the test case click anywhere in the document to witness this behavior)

Actual Results: 

Something noticable happens.

Expected Results: 

Nothing noticable should happen.

Build Date & Platform Bug Found: 

Linux 2000-01-25-20 (M13)

Additional Builds and Platforms Tested On: 

none

Additional Information: 

I'm using event capturing here, but the problem manifests itself
without it also.

Comment 2

18 years ago
Could you tell me if the bug still exists? 
Because when I clicked on the test page I get an ALERT window with "Event-Type:" 
or "Node-Type:" information.  
(Reporter)

Comment 3

18 years ago
Created attachment 6038 [details]
simpler test case demonstrating problem
(Assignee)

Comment 4

18 years ago
Setting milestone
Target Milestone: M16

Comment 5

18 years ago
M16 has been out for a while now, these bugs target milestones need to be 
updated.
(Assignee)

Comment 6

18 years ago
Adding [DOM] prefix to bugs related to DOM Level 0, 1, or 2 
compatibility/compliance.
Status: NEW → ASSIGNED
Summary: remove event listener (removeEventListener method) fails → [DOM] remove event listener (removeEventListener method) fails
(Assignee)

Comment 7

18 years ago
Have a fix.

nominating nsbeta3
Keywords: nsbeta3
Whiteboard: [fixinhand]
(Assignee)

Comment 8

18 years ago
Updating Milestone to M18.
Target Milestone: M16 → M18

Comment 9

18 years ago
Mass update:  changing qacontact to ckritzer@netscape.com
QA Contact: janc → ckritzer

Comment 10

18 years ago
Marking nsbeta3+...
Whiteboard: [fixinhand] → [fixinhand][nsbeta3+]

Comment 11

18 years ago
Joki's fixes have been checked in by saari.  Marking fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 12

18 years ago
Marking VERIFIED FIXED on:
- LinuxRH62 2000-09-07-08-M18 Commercial
- Win98     2000-09-07-08-M18 Mozilla
- MacOS86   2000-09-07-04-M18 Commercial
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.