Javascript bookmarklet causes Block Popup Windows option to disable

RESOLVED INVALID

Status

()

Firefox
Preferences
RESOLVED INVALID
13 years ago
11 years ago

People

(Reporter: Mike Odom, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

And I've been getting pop-ups lately, and noticing that my Block Popup Windows
option keeps unchecking itself. I finally figured out it was my javascript item
in my personal toolbar.

Reproducible: Always
Steps to Reproduce:
1. Create a bookmark on the personal toolbar that creates a javascript window.
javascript:void(open('http://www.google.com')); works.
2. Make sure Block Popup Windows is enabled.
3. Click the bookmark.

Actual Results:  
Block Popup Windows is now disabled.

Expected Results:  
Block Popup Windows option should have remained enabled.
WFM
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
(Reporter)

Comment 2

13 years ago
Started uninstalling extensions. Looks like it was just an older version of the
Tabbedbrowser Extensions. Updated, works now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.