forwarding mail message with the same subject and attachment name causes problems for outlook express

RESOLVED INVALID

Status

RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: tim_allen, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

Here's what happened:
I received a mail from a colleague that had a subject called Faulty I1 - 98.xls
The message also had a file attached of that same name. He is using outlook and
I am using thunderbird. I then forwarded this message on to another colleague
who is using outlook express. When she double clicked the attachement, excel
opened up, displaying the code from the forward mail, rather than the excel file.

Reproducible: Always
Steps to Reproduce:
see details



I cannot provide the email for privacy reasons, but if you need to I can
probably reproduce this with non-sensitive data.
(Reporter)

Comment 1

14 years ago
Actually, it seems that this bug occurs any time you forward a mail message with
a subject of .xls to someone using outlook express. Outlook express takes the
attached message as being and excel file.

Comment 2

14 years ago
I think this is almost certainly an issue with OE and nothing to do with
Thunderbird but some additional testing might be useful as I was unable to
reproduce this bug correctly with Thunderbird and Outlook (I don't have OE to hand).

Can you forward an e-mail as an attachment with a subject ending in .xls to OE
and take a look at the headers. I'm expecting the attachment to be described in
the headers similar to...

Content-Type: message/rfc822;
name="test.xls"
Content-Transfer-Encoding: 7bit
Content-Disposition: inline;
filename="test.xls"

If the content type is indeed set correctly ('message/rfc822') then OE is
ignoring the content-type and opening the attachment based on the file
extention. This wouldn't be suprising and I'll then close this bug.
(Reporter)

Comment 3

14 years ago
Yes, it is as you suppose.

From - Wed Sep 01 11:20:13 2004
X-Mozilla-Status: 0001
X-Mozilla-Status2: 10800000
Message-ID: <413523CC.1010401@transtech.net.au>
Date: Wed, 01 Sep 2004 11:20:12 +1000
From: Tim Allen <sender@transtech.net.au>
User-Agent: Mozilla Thunderbird 0.7 (Windows/20040616)
X-Accept-Language: en-us, en
MIME-Version: 1.0
To: Marni Hall <recipient@transtech.net.au>
Subject: [Fwd: test message.xls]
Content-Type: multipart/mixed;
 boundary="------------020903000000050503010900"

This is a multi-part message in MIME format.
--------------020903000000050503010900
Content-Type: text/html; charset=us-ascii
Content-Transfer-Encoding: 7bit

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
  <title></title>
</head>
<body bgcolor="#ffffff" text="#000000">
just a test.<br>
</body>
</html>

--------------020903000000050503010900
Content-Type: message/rfc822;
 name="test message.xls"
Content-Transfer-Encoding: 7bit
Content-Disposition: inline;
 filename="test message.xls"

Return-Path: <tim@transtech.net.au>
Received: from [203.44.28.203] ([203.44.28.203])
	by wattle.transtech.net.au (8.12.10/8.12.10) with ESMTP id i811IOvw008950
	for <tim@transtech.net.au>; Wed, 1 Sep 2004 11:18:24 +1000
Message-ID: <41352398.3020106@transtech.net.au>
Date: Wed, 01 Sep 2004 11:19:20 +1000
From: Tim Allen <tim@transtech.net.au>
User-Agent: Mozilla Thunderbird 0.7 (Windows/20040616)
X-Accept-Language: en-us, en
MIME-Version: 1.0
To: Tim Allen <tim@transtech.net.au>
Subject: test message.xls
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit




--------------020903000000050503010900--

Comment 4

14 years ago
I'll close this as INVALID since it appears to be an issue with OE ignoring MIME
types and openning the filebased upon it's extention alone. Might be a good
oppertunity to migrate your colleague to Thunderbird :-)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.