Single-clicking on site info icon or critical updates icon has no effect

RESOLVED INVALID

Status

()

Firefox
Toolbars and Customization
--
minor
RESOLVED INVALID
14 years ago
12 years ago

People

(Reporter: Thomas Rutter, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040831 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040831 Firefox/0.9.1+

Some icons on the right hand side of the status bar require a single-click, and
others require a double-click.  The "Critical Updates" icon does nothing on a
single-click, but does something on a double-click.

It just 'feels' somehow that this feature doesn't work properly, because it
doesn't do anything on a single click.  Even if it just popped up a menu on
single click it would feel more 'right'.  Alternatively, it could pop up a
tooltip saying "Double click here to open ...".

The same goes for the "Page info" icon, which is visible when viewing a secure
page.  Single-clicking on it does nothing, and it's not obvious as to why it
requires a double-click if there's no single-click action.

Reproducible: Always
Steps to Reproduce:
1. On a recent nightly, observe the "Critical Updates Available" icon.
2. Click this icon.
Actual Results:  
Nothing happens

Expected Results:  
The icon should have a single-click action.
icon moved from statusbar->toolbars

->INVA
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Updated

12 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.