Update Extension: MagicSLR 0.8.0 for TB

RESOLVED INVALID

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED INVALID
13 years ago
2 years ago

People

(Reporter: AlexIhrig, Unassigned)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7) Gecko/20040803 Firefox/0.9.3

Target application: Thunderbird
Target apps versions: 0.7 - 0.9.1+

Extensions Name: MagicSLR
Extensions Version: 0.8.0
Extensions ID: {0130B7FE-6AE0-40d9-AE2D-128AA498AD94}
Extensions Author: Alexander Ihrig <thunder@diepause.de>
Extensions Locales: en-US, de-DE
Extensions UpdateURL: not specified, so it would be update.mozilla.org
Extensions Homepage: http://www.thunderbird-mail.de/extensions/magicslr/index-en.php

Short description:
Adds extended functions/buttons to GET and SEND messages in online and offline mode.

Requires:
Installed Offline functions (offline.jar)

Long description including Screenshots:
Please have a look and provide a link to this website:
http://www.thunderbird-mail.de/extensions/magicslr/index-en.php

As you can see on the website, there is a separate version for Mac OS X users.
This version differs only in the skin! I believe we / you can't host both
versions on the update.mozilla.org website, so please host the Windows/Linux
version with the qute related theme:

http://downloads.mozdev.org/gtl/extensions/magicslr/magicslr-0.8.0-qute.xpi

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Updated

13 years ago
Assignee: psychoticwolf → jedsbugs

Updated

13 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 1

13 years ago
Sorry for the delay
In Queue, Please re-open this bug for any changes or updates.
Whiteboard: in queue
(Reporter)

Comment 2

13 years ago
You don't have linked the correct download link in the database.

It should be:
http://ftp.mozilla.org/pub/mozilla.org/extensions/magicslr/magicslr-0.8.0-qute.xpi

Regards
Alex Ihrig
Status: ASSIGNED → NEW

Comment 3

13 years ago
Wolf -
These are now pointing to the URL of the approval queue, not the mirrors
/files/approval/magicslr-0.8.0-qute.xpi
Assignee: jedsbugs → psychoticwolf
Whiteboard: in queue

Comment 4

13 years ago
Seems to be working now.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

13 years ago
Version 0.8.1 is available.
Compatible to Thunderbird 0.7 - 0.9

http://downloads.mozdev.org/gtl/extensions/magicslr/magicslr-0.8.1-qute.xpi

Only small internal changes in locales contents.rdf.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 6

13 years ago
Bulk Moving Extension/Theme listing bugs to new component.
(Filter: masslistingspam)
Component: Update → Listings
Product: mozilla.org → Update
Version: other → unspecified

Comment 7

13 years ago
Needs testing by a third party.
Assignee: psychoticwolf → nobody
Status: REOPENED → NEW
(Reporter)

Comment 8

13 years ago
Version 0.9.0 is available:

Compatible to Thunderbird 1.0

Skin updated for the new smaller Toolbar icons. locales for de-DE, en-US and
it-IT included. All locales contents.rdf have the chrome:name="ab-CD"

http://thunderbird.dnsalias.net/downloads/extensions/magicslr-0.9.0-qute.xpi

Updated

13 years ago
Summary: List new Thunderbird Extension: MagicSLR 0.8.0 → Update Extension: MagicSLR 0.8.0

Comment 9

13 years ago
tested+
User Agent: Mozilla Thunderbird 1.0 (X11/20041206)

Extension is working fine. 
One remark: This extension supports three locales, en-US, it-IT and de-DE. I
have tested the extension in the en-US Thunderbird, but the description in
"Tools | Extensions" is in German.

Comment 10

13 years ago
Marking tested+ according to comment 9.

(I'm not sure about the locale thing, perhaps it's a profile issue. IMO, the
extension should be listed anyway, as it matches the "installs;works/adds
UI;uninstalls" criteria.)
Whiteboard: tested+

Updated

13 years ago
Assignee: nobody → Bugzilla-alanjstrBugs
(Reporter)

Comment 11

13 years ago
There is no way to include the description in Tools > Extensions in more than
one language. It's an original german extension, so it has only a german
descrition in this dialog.

All other dialogs, toolbar buttons and alerts are available in the included
different locales (at this time en-US, de-DE and it-IT). If there are questions
about the extension go to:

www.thunderbird-mail.de/extensions/magicslr/index-en.php
(Reporter)

Comment 12

13 years ago
BTW:

This extension exists as pinstripe version (Mac OS X), too.

At update.mozilla.org we're not able to distribute both versions. To get the
download, go to the above mentioned website.

Comment 13

13 years ago
(In reply to comment #11)
> There is no way to include the description in Tools > Extensions in more than
> one language. It's an original german extension, so it has only a german
> descrition in this dialog.

You're saying that locales does not apply to this field?  Please file a bug.
(Reporter)

Comment 14

13 years ago
@ comment #13:

Here's the related bug:
https://bugzilla.mozilla.org/show_bug.cgi?id=257155

Comment 15

13 years ago
I have a small request.  For your next release, can you make the default
description in EM English?  I'll upload magicslr-0.9.0-qute.xpi tonight.
Status: NEW → ASSIGNED

Comment 16

13 years ago
And this was for OSX only, right?  Next time, can you include OSX or darwin in
the file name?
Whiteboard: tested+ → In queue
(Reporter)

Comment 17

13 years ago
@ comment #16:

Qute is the Theme for win32 / linux > related to the qute theme:
http://thunderbird.dnsalias.net/downloads/extensions/magicslr-0.9.0-qute.xpi

Pinstripe is the Theme for mac os x > related to the pinstripe theme:
http://thunderbird.dnsalias.net/downloads/extensions/magicslr-0.9.0-pinstripe.xpi

There is NO platform specific code in the extension - only the theme is different.

Comment 18

13 years ago
Ah.  My mistake.  Does TB for Win/Lin not have Winstripe?
Whiteboard: In queue
(Reporter)

Comment 19

13 years ago
@ comment #18:

When MagicSLR was born, it was the qute theme. In Thunderbirds chrome the theme
is still "qute.jar". And the theme is not the same as in Firefox 1.0. BTW the
theme is still from Arvid Axelsson.

Updated

13 years ago
Assignee: Bugzilla-alanjstrBugs → nobody
Status: ASSIGNED → NEW

Updated

13 years ago
Summary: Update Extension: MagicSLR 0.8.0 → Update Extension: MagicSLR 0.8.0 for TB
(Reporter)

Comment 20

13 years ago
If there is still someone interested to host this extension on
https://addons.update.mozilla.org/ , here is information about the actual version:

1) MagicSLR 0.9.2 is the actual version
2) The GUIDs have changed for international users and because of the different
versions for win/linux and mac. The old GUID (see comment #1) is outdated and
MUST be changed!
3) Included locales: de-DE, en-US, fr-FR, es-ES, it-IT, nl-NL, pl-PL
4) UpdateURL: http://update.thunderbird-mail.de/update_multilang.rdf
5) Homepage: http://magicslr.thunderbird-mail.de/index-en.php

Downloads:

Mac OS X Version (pinstripe skin): {61efbf20-6b7-d931-a8b2-3d4b6304699}
http://thunderbird.dnsalias.net/downloads/extensions/MagicSLR_mac_0.9.2_multilang.xpi

Windows/Linux Version (qute skin): {6e071e83-d8d6-8ca9-6129-eb8e8144596f}
http://thunderbird.dnsalias.net/downloads/extensions/MagicSLR_win_linux_0.9.2_multilang.xpi

This latest version is compatible to Thunderbird 0.7 - 1.0+ and includes the new
install.manifest file.
(Reporter)

Comment 21

13 years ago
Ups,

MagicSLR 0.9.2 is only for Thunderbird 1.0 - 1.0+ because of Thunderbirds
skin-changes from 0.9+ to 1.0 final.
(Reporter)

Comment 22

13 years ago
Now ja-JP locale is included in MagicSLR 0.9.2.

Comment 23

13 years ago
Please use the Developer Control Panel to update your listing
https://addons.update.mozilla.org/developers/
Status: NEW → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → EXPIRED

Comment 24

13 years ago
Made a mistake with status
Status: RESOLVED → REOPENED
Resolution: EXPIRED → ---

Updated

13 years ago
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 25

13 years ago
I've been checking in two new versions:

- "MagicSLR (Windows & Linux)"
- "MagicSLR (Mac)"

But I'm not able to remove the old "MagicSLR" 0.8.0 out of your database - it
would be a good idea to do this.

MagicSLR (Windows & Linux) uploaded again, so you can give it a new try.
Something must have been damaged at the past upload. The Screenshots for this
version are not shown in the Dev Control Panel? And the are name as *.jpg - but
all screenshots are *.png?! How could this happen?
(Reporter)

Comment 26

13 years ago
It's anoying...

Don't know, why the win/linux version is not operable, when you're testing. The
file is correct on my local machine and it is used by many users, which have
donwloaded direct from my website.

There must be a problem with the upload to your server. Maybe the problem occurs
because of the given file name or the extensions name in the dev control panel.
I'm wondering, why the mac version is working for you.

The file itself is okay, the problem occurs only by the upload.
AMO BUGSPAM FOR COMPONENT MOVE AND DELETE (FILTER ME)
Component: Listings → Web Site
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.