M13 Repeated clearing of drawing surface when loading pages

VERIFIED WORKSFORME

Status

SeaMonkey
General
P3
normal
VERIFIED WORKSFORME
19 years ago
14 years ago

People

(Reporter: Simon Lucy, Assigned: Christine Begle)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
When a page is loaded the drawing surface is cleared repeatedly, to black, then 
grey, then black, then grey.

Built from M13 without any modifications, Redhat Linux 6.1, Processor K6 2 
475Mhz, 64Mb ram.

Comment 1

19 years ago
Assigning all open "nobody@mozilla.org" bugs to "leger@netscape.com" to weed 
thru.
Assignee: nobody → leger

Comment 2

19 years ago
does the page load at the end? or does it change colors and nothing is displayed?

Mozilla does such redraws a lot, as it parses the HTML code.  Does this also
happen on each page?

Comment 3

19 years ago
slucy@objectivesw.co.uk : can you provide an example URL for this problem? Or, 
does this happen on 'any' page you load (if so, can you provide some further
details on your x-server, monitor, graphics hardware, etc.) -- There are 
certain pages that will do this 'blank out' while loading, but if this happens
on many sites for you, then that would point more towards a particular 
combination of OS/x-server/hardware etc. Thanks!
(Reporter)

Comment 4

19 years ago
It happens on any of the test pages, I've only been running it on local pages.  
The GTK build does it reliably on this setup on every load of a page.  The Xlib 
build is less noticeable.  Because this machine has an SiS 6326 video card 
imageblt and patblt are switched off and sw_cursor is switched on.  In general 
the whole X system is slow.

I'd put it down to a slow graphics engine making obvious something which would 
normally be hidden.  In any event it looks as if there are too many invalidate 
rectangle processes going on.  
(Assignee)

Comment 5

19 years ago
reassigning browser-general bugs (again!) so triagers can find all the bugs 
with one query.
Assignee: leger → cbegle
QA Contact: nobody → asadotzler

Comment 6

19 years ago
reporter - could you please try m14?

thanks
(Reporter)

Comment 7

19 years ago
I can't reproduce it with M14.  I'd guess the changes removing all the 
reflowing fixed it.

Comment 8

19 years ago
calling this worksforme as per reporters comments.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 9

19 years ago
marking verified tested on linux build 2000032208. i know there is a bug logged
that says background is getting painted twice. And there used to be a bug (which
has since been fixed) that affected at least bugzilla where the page would
flicker between black and garbage...
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.