If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Make a css background animated gif restart for :hover elements when mouse enters this element (rollover)

RESOLVED DUPLICATE of bug 239197

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 239197
13 years ago
13 years ago

People

(Reporter: Hadrien Nilsson, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

In order to create pure CSS menus with a nice animated effect when the mouse
enters the element, GIF images are a convenient choice. Such a CSS code can be
used :

a { background-image: url("button.gif"); /* more properties here */ }
a:hover { background-image: url("button-hover.gif"); /* more properties here */ }

with "button-hover.gif" being an animated gif which does not loop.

Unfortunately, Firefox 0.9.1 (Gecko/20040626) does not reset the current frame
displayed of the animated gif when the mouse enters the element. The animation
is only played once. Once the animation is done, we only get the last frame of
the animation.

It would be more convenient to have the animation restarted each time the mouse
enters the element.


Reproducible: Always
Steps to Reproduce:
1.Go to the test page
2.Move the mouse on the buttons, check the animation
3.Move your mouse out and in the buttons

Actual Results:  
The gif animation is not restarted, you only get the last frame of the animation
when your mouse cursor is inside a button.

Expected Results:  
The gif animation should be restarted each time the mouse cursor enters a button.

The test page acts as expected on MSIE 6 and Opera 7.52
Already fixed on trunk.  Please test layout bugs with trunk builds before filing
bugs.

*** This bug has been marked as a duplicate of 239197 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

13 years ago
Thanks. I'm used to avoid duplicates but it seems the simple query page do not
list resolved bugs :/
You need to log in before you can comment on or make changes to this bug.