Popup appearing while dragging bookmarks on the sidebar locks the mouse.

VERIFIED DUPLICATE of bug 100180

Status

VERIFIED DUPLICATE of bug 100180
14 years ago
11 years ago

People

(Reporter: 6jju4k002, Assigned: p_ch)

Tracking

({hang})

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a3) Gecko/20040817
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a3) Gecko/20040817

No details to add:
Summary and steps to reproduce, and actual results say it all!

Reproducible: Always
Steps to Reproduce:
1. Ensure the bookmark tab on the sidebar is open
2. Load a web page that you know will fail to load, displaying a pop-up error.
2. While waiting for the load to complete, drag a bookmark, and
    keep dragged till popup appears.
3. Attempt to click on "OK" in popup.
4. Attempt to drag another bookmark.
5. Press enter.

Actual Results:  
When the popup appears, the drag target marker (The broad dark grey line that 
marks where the bookmark would go) is left on the bookmarks sidebar.
The mouse pointer changes from drag to non-drag.
The UI ceases to respond to the mouse:
   The pop-up does not respond to a click on the "OK" button.
   The sidebar does not respond to further drags.
Pressing enter closes the pop-up, and returns the UI to a usable state.
The drag target marker remains visible on the sidebar, till another drag is
attempted.

Expected Results:  
The drag in the sidebar should be properly terminated, and focus
moved to the pop-up.

I consider this a critical bug, as novice users will not consider attempting to
use the keyboard to unlock the mouse. They will consider mozilla hung.

If this doesn't get fixed in the release, maybe the work-around of pressing
enter should be placed in the release notes?
Whiteboard: DUPEME

Comment 1

14 years ago
Looks like a duplicate of bug 100180. 
(Reporter)

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 100180 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
V.Duplicate
Severity: critical → normal
Status: RESOLVED → VERIFIED
Keywords: hang
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.