Closed Bug 257676 Opened 16 years ago Closed 14 years ago

New Option: Delete Messages from POP3-server only when they go to trash (locally)

Categories

(Thunderbird :: Preferences, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 226839

People

(Reporter: diemer, Assigned: mscott)

References

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7) Gecko/20040823 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7) Gecko/20040823 Firefox/0.9.3

There is already an option to keep mails on the POP3server and only delete them
when they are moved/deleted from the local Inbox. If I filter messages locally
(e.g. I filter Mailinglists to seperate folders), the emails will get deleted on
the server. I'd rather have emails only deleted on the server, when they go to
local trash.

Also, a function to remove selcted mails from server would be cool (seperate bug
report?)

Reproducible: Always
Steps to Reproduce:
I also (as many others) want to read my E-Mail at different locations (work / 
home). So the Option "Delete from Server when deleted OR WHEN MOVED FROM INBOX" 
isn't useful for me. My Suggestion is: 

[] Delete From Server When Deleted From Trash 
[] Delete From Server When Moved From Inbox 

In my opinion hardly anyone will really use Option 2 but it would let many 
people be able at last to use the first Option and delete mail from server even 
if reading mail at 2 locations. 

Sorry to say: Outlook Express has exactly this feature - that is the reason i 
still use Outlook Express at home while using Thunderbird at work... 

Hope to see that feature in Thunderbird 1.0, it shouldn't be that hard to 
implement. 

Greetings, 
Magganpice
I also use thunderbird both at work and at home, and for the same trivial reason
I don't use the "Delete from server when deleted or when moved from inbox" option.

I encounter this problem: the spam which isn't automatically filtered at one
location (i.e. work or home) have to be manually marked as spam. So when I
download my mails from the second location, I have to do that tedious task once
again! In addition, the mails both automatically and manually marked as spam are
not deleted from the server and use many disk space on it, which reduces free
space available for incomming mails...

I think that many people would appreciate to have the choice of not
systematically deleting messages when they move out of inbox, and I'm sure that
this enhancement would'nt be so hard programming task...
Yes this is a feature that would be greatly appreciated, i have to say that this
the only features that I miss, coming from "Entourage".

I believe their system of having an icon beside the "read" flag with a envelop
logo with a cable that means that the message is still on the server is the
right solution. Changes are made by right-click where a pop-up menu gives you
the possibilities:

- Delete message from server
- Leave message on server

Message is of course deleted at next connection.
All of what you've mentioned here is pretty much covered under bug 47297.

As that bug covers several things related to message deletion, I won't dupe this
one yet, though.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
Register one more emphatic vote for the Eudora style delete-from-server behavior
in Thunderbird.

I check my POP email from at least five different computers (all using
Thunderbird). I designate my main home computer the "master", and remove mail
from the server when downloaded on that machine. All other machines leave the
mail on the server.

Thunderbird needs to provide both of the following:

1. An option to mark individual emails for deletion from the server upon the
next download.

2. An option to automatically remove emails from the server when emptied from
the trash.

That way, when I check my mail at work and delete the junk, I don't have to
download the junk a second time when I get home.

Don't tell me to use IMAP and don't tell me it can't be done. Surely the
Thunderbird developers are at least as smart as those who work on Eudora! Wink
I vote to this too. I can't read messages from more computer, 'cause of lack of
this feature.
If there is any chance to implement it to 1.1 final, please. I would be very
overawed.

Thanks in advance,
Tomyellow
*** Bug 318296 has been marked as a duplicate of this bug. ***

*** This bug has been marked as a duplicate of 226839 ***
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.