Preferences dialog width too small when viewing Privacy settings, contents are partially hidden from view

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
14 years ago
12 years ago

People

(Reporter: dbeckham, Assigned: bugzilla)

Tracking

({platform-parity})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

The contents of the privacy tab in the preferences dialog are partially hidden
from view on the right side of the dialog when viewing "Download Manager
History", "Cookies" or "Cache".

This seems to be a MacOS X specific issue.  I have verified that the Windows
Firefox behavior is correct, but I'm unable to verify on Unix/Linux.




Reproducible: Always
Steps to Reproduce:
1. Open Firefox on MacOS X
2. Open Preferences dialog
3. Select Privacy tab
3. Click on "Download Manager History", "Cookies" or "Cache"
Actual Results:  
The expander elements are opened and the contents of the window are resized such
that part of the contents are now hidden from view.

Expected Results:  
The XUl elements should be laid out in such a way as to properly wrap so that no
part of the window is unintentionally hidden from view.

It looks like either the dialog needs to be resized to fit the layout inside the
expander elements, or the layout needs to be reworked to take into account the
size of the Mac UI.
(Reporter)

Comment 1

14 years ago
Created attachment 157637 [details]
Example Screenshot #1
(Reporter)

Comment 2

14 years ago
Created attachment 157638 [details]
Example Screenshot #2
Please try latest aviary build:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-0.9/

I'm using: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.3)
Gecko/20040906 Firefox/1.0 PR (NOT FINAL)

and I see a horizontal scrollbar (which isn't exist in your screenshots).
QA Contact: mconnor → bugs.mano
(Reporter)

Comment 4

14 years ago
Whether or not a horizontal scrollbar exists in the latest build isn't really
the issue here.  The information in the Privacy preferences pane should never
extend past the inside of the iframe it's a child of. It doesn't on the Windows
build and it shouldn't on the Mac OS build.  The contents should be
appropriately laid out so that they wrap properly and never need a horizontal
scrollbar in the first place.  A horizontal scrollbar here is either a bug or
bad UI design.  I would think it's a bug, since the Windows build doesn't have
this issue.  
confirmed.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

14 years ago
Flags: blocking-aviary1.0mac?
*** Bug 270898 has been marked as a duplicate of this bug. ***

Comment 7

14 years ago
I have been using firefox on linux and I see the same problem so it is not
specific to OSX.
I am using
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

I also find that when I start up the preferences panel, and go to 'General'
the last item in the panel, namely 'connections' required for chaning proxy
is obscured because the box is not tall enough. This may be because I have
chosen a larger than normal font size because of myopia. Perhaps the panel size
takes no account of font size, which I would regard as a serious bug.

This can make it very difficult to find the place to configure a proxy
server.

I guess I should report that as a separate bug.

In general, as a long time mozilla user I think the overall design of the
mozilla preferences panel, with expandable menu on the left is much better than
the firefox preferences panel, (except that on mozilla the font is too small and
I cant find a way to enlarge it.)

Aaron
==
www.cs.bham.ac.uk/~axs
Happens on Linux and Mac, setting All/All. Note that it has not been reported on
PC/Windows.
OS: MacOS X → All
Hardware: Macintosh → All
*** Bug 274515 has been marked as a duplicate of this bug. ***

Comment 10

13 years ago
I'm uploading an additional example of the pref window being too small. In this case, it is cut off at the bottom instead of the side. This is on Mac OS X 10.4.3.

Comment 11

13 years ago
Created attachment 203639 [details]
screenshot of cut-off pref/privacy window

Comment 12

13 years ago
Additional detais:
FF release: 1.5 RC3
Shows same kind of issue on pref window for all portions of pref window, not only privacy section.

Comment 13

13 years ago
I have seen this with 1.5 final on Linux with GNOME. I think the problem is that my default GTK2 font is size 8 and not the default size 10. When using 10, the dialog is perfectly sized, when using 8 it is taller and thinner which cuts off some of the interface, or causes overlapping.
The preferences dialog needs to take the current font size in to account, which the rest of the interface does very well.

Comment 14

12 years ago
WFM in latest prefwindow.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME

Comment 15

12 years ago
Problem no longer present for me. Firefox v 1.5.0.6 on Linux
You need to log in before you can comment on or make changes to this bug.