Bug 257709 (formspacing)

{inc} Form containing drop-down with default value loses its spacing below on reload

VERIFIED WORKSFORME

Status

()

Core
Layout: Form Controls
VERIFIED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Marc Stager, Unassigned)

Tracking

({regression, testcase})

Trunk
x86
Windows XP
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7.2) Gecko/20040803
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7.2) Gecko/20040803

This is an upload of an HTML file I use for my start page. In my actual file
the blank cells at the bottom section are filled by frequently accessed links.

This page looks fine with IE6 and Opera, and was also OK with Mozilla 1.6.

With Moz 1.72, the look changes when it is reloaded and again when the 
address on the navigation bar is highlighted and clicked on. 

Try it. 

Inconsistent HTLM coding, it was better in 1.6. NOT compatible with IE6 which
should be THE HTLM standard for cross-platform consistency if only by virtue of
their 70% browser usage. Most pages look different when compared on both. 
Some don't work at all on Mozilla.

(see "Bad example" above. Bad example, maybe, but too true. Why do you insist
on being different?)




Reproducible: Always
Steps to Reproduce:
1. Just click on the link
2.
3.



Expected Results:  
See Mozilla 1.6, IE6, orOpera.

Updated

14 years ago
Assignee: general → nobody
Component: Browser-General → Layout
QA Contact: general → core.layout

Comment 1

14 years ago
WFM, 2004-08-28-06 trunk Linux.

Marc, please try Mozilla 1.8 Alpha 3 and see if it still occurs, thanks.
http://www.mozilla.org/releases/
(Reporter)

Updated

14 years ago
Alias: formspacing
Severity: major → normal
Keywords: helpwanted
(Reporter)

Comment 2

14 years ago
Same thing is happening in Firefox 0.9.3

FORMATTING WAS WAS OK WITH MOZILLA 1.6. ! 
-- and still looks fine with IE and Opera.

PLEASE put it back  the way it was.

Comment 3

14 years ago
WFM, 2004-09-09-16 trunk Windows XP. (It renders almost identical to IE6.)

Marc, first we need to establish if this is a problem that still occurs with
the current Mozilla code. To do that you need to test with builds that are
based on the latest code, which you can find here:
http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/latest/

I can't reproduce the problem with the latest builds on Linux and Windows XP.
I can reproduce the problem in Firefox 0.9.3 on Windows XP.
This means that most likely the problem is known and has been fixed already.

So please try the latest build from the link above an tell me if that
solves the problem for you too, thanks.
Keywords: helpwanted

Comment 4

14 years ago
Confirming on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3)
Gecko/20040925 Firefox/0.10. Testcase to follow.
Status: UNCONFIRMED → NEW
Component: Layout → Layout: Form Controls
Ever confirmed: true
Keywords: regression, testcase
OS: Windows Server 2003 → Windows XP
QA Contact: core.layout → core.layout.form-controls
Summary: Formatting faults - forms spacing. Bad appearance. → {inc} Form containing drop-down with default value loses its spacing below on reload

Comment 5

14 years ago
Created attachment 161107 [details]
testcase
(Reporter)

Comment 6

14 years ago
(In reply to comment #5)
> Created an attachment (id=161107)
> testcase

Fixed with Mozilla 1.8a4.
Still a problem with Firefox .9.3.0 and 1.0

____________ Marc Stager

Comment 7

13 years ago
WFM, 2005-01-28-05 trunk Linux
WFM, 2005-01-28-04 trunk Windows XP

-> WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Comment 8

13 years ago
Verified by Reporter in comment 6
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.