Incorrect date and time formats in export file (ics)

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
14 years ago
12 years ago

People

(Reporter: Pascal.Kreyer, Assigned: mostafah)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.7.2) Gecko/20040817
Build Identifier: Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.7.2) Gecko/20040817

Format in $HOME/.mozilla/<profile>/*/Calendar/CalendarDataFile.ics file :

DTSTART:20040908T164000
DTEND:20040908T164000

And the format in the export file : 

DTSTART:20040908T144000Z
DTEND:20040908T144000Z

This make a problem on different Calendar Server. For example with : Sun One
Calendar Server 5.1.1. The result is :  we have between 2 or 4 hours of
different with the real time.

Reproducible: Always
Steps to Reproduce:
1. Export an events in ics format
2. And compare the ics file with the correct event entrie in the
$HOME/.mozilla/<profile>/*/Calendar/CalendarDataFile.ics file


Actual Results:  
I see this result :

< DTSTART:20040908T164000
< DTEND:20040908T164000
---
> DTSTART:20040908T144000Z
> DTEND:20040908T144000Z


Expected Results:  

< DTSTART:20040908T144000Z
< DTEND:20040908T144000Z
---
> DTSTART:20040908T144000Z
> DTEND:20040908T144000Z

Comment 1

14 years ago
Export produces UTC times (perhaps some programs which would import can't deal
with RFC2445 time zone definitions, but most programs should be able to deal
with UTC times).

You can store events in UTC times by turning on the preference "Store Dates in
Universal Time".  (Maybe this should be on by default?)
(Reporter)

Comment 2

14 years ago
I don't see the preference "Store Dates in Universal Time". Maybe available only
on Windows platforms.

Comment 3

14 years ago
It's first on the 'General' page, checked in 2004-06-30 so should be in Calendar
releases since then.
Reporter,
Are you still experiencing this issue?
(Reporter)

Comment 5

14 years ago
I don't see the preference "Store Dates in Universal Time". It's the same
problem with  Mozilla 1.7.3 Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.7.3)
Gecko/20040919.

Comment 6

14 years ago
I think the "Store Dates as Universal Time" feature was added around june 2004,
after the 1.7 branch forked from the trunk that spring.  

As I recall, there are no xpi's for SunOS, so the reporter is probably using a
Mozilla 1.7.3 build that includes Calendar.  The calendar in the 1.7.3 branch is
not being updated, as other platforms install from an xpi built from the trunk
(we maintain xpi compatibility with 1.7.3 in the trunk code).

Comment 7

14 years ago
This is quite old, and worksforme.  Reporter, are you still experiencing this or
can this bug be closed?
(Reporter)

Comment 8

14 years ago
(In reply to comment #7)
> This is quite old, and worksforme.  Reporter, are you still experiencing this or
> can this bug be closed?

You can close this bug.

Updated

14 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: gurganbl → general
You need to log in before you can comment on or make changes to this bug.