If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Frequent simultaneous failure of multiple GUI functions.

RESOLVED WORKSFORME

Status

Core Graveyard
GFX: Mac
--
major
RESOLVED WORKSFORME
13 years ago
9 years ago

People

(Reporter: Gareth Randall, Assigned: Simon Fraser)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.2) Gecko/20040803
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.2) Gecko/20040803

Mozilla 1.7.2 and Mozilla 1.6 are afflicted by a bug which, for no discernable
reason, frequently results in a whole list of GUI functions failing simultaneously.

The failures are:

1. Cursor stops flashing in location text box (but is still visible).
2. For any dialogs that come up with OK/Cancel buttons, the buttons change
colour on clicking but nothing happens, and the dialogs cannot be closed.
3. Bookmarks drop-down menu ceases to automatically expand sub-menus when mouse
hovers over them.
4. Auto-completion stops working in location text box. No drop-down box appears.
5. Typing a URL and pressing Enter sometimes has no effect i.e. nothing happens.

All of these effects occur together. There have been no cases when only one or a
few have occurred independently.

This almost always results in the Mozilla instance becoming unusable and having
to be restarted. In fact, it is just about the only reason I have to quit Mozilla.

On average I experience this once a day, for a typical usage of 1 hour per day,
but sometimes within just a few minutes of starting Mozilla.

I have found no workaround or action that causes these behaviour problems to
cease and return to normal.

Because a multitude of components are affected, perhaps this bug can be
diagnosed by determining the commonality between the symptoms? I realise that my
"steps to reproduce" below is lacking hard detail :-)

I can make stack traces and core dumps available if people want them.

Reproducible: Sometimes
Steps to Reproduce:
I can't "reproduce" it as such but it happens so frequently that it is *the*
reason why I have to restart Mozilla.

1. Open Mozilla.
2. Wait for a strange effect to occur, e.g. notice that location box cursor has
stopped flashing.
3. Observe that all other noted effects are now present.

Actual Results:  
Browser, Mail client and other components all exhibit symptoms described above.

Expected Results:  
Not behave in this way.

Only seen on MacOSX versions of Mozilla.

Never seen on Win32 or Linux x86 versions.
(Reporter)

Comment 1

13 years ago
Moving to GFX: Mac.

Reason for this is that the bug described occurs when I use the default
"classic" look and feel which uses native Mac OS X widgets.

A friend of mine who only runs the Modern theme and has never experienced the
problems I describe.

Consequently I think it is highly likely to be a Mac GUI-specific issue.
Component: Location Bar → GFX: Mac
(Reporter)

Comment 2

13 years ago
(Should have added that)  I've switched my own Mozilla to use Modern theme and
haven't seen the bug reappear yet.
(Reporter)

Comment 3

13 years ago
Raising to major, as this bug has now bitten me when running the "Modern" theme
too. I am still having to "Force Quit" Mozilla.

I'm on Mac OS X 10.3.5, latest patches, with no manual customisation I should
point out.


I'm surprised that no-one else has responded. Is no-one else having this problem
or have all the Mac users silently deserted to Safari?
Severity: normal → major
(Reporter)

Comment 4

13 years ago
Mozilla 1.7.3 is affected as well.

Comment 5

13 years ago
*** Bug 260187 has been marked as a duplicate of this bug. ***

Comment 6

13 years ago
Reporter, after your rant in bug 260187, did it even occur to you that we're too
busy ? Nobody seems to look for existing bugs anymore (there's at least a 95%
probability that the bug was filed before !)

Your problems seems to indicate bug 232715, but you don't mention that you were
sleeping.
(Reporter)

Comment 7

13 years ago
I don't mention I (the disk) was sleeping because I wasn't. I've seen this
happen within, say, 30 seconds of opening Mozilla.


Now there are two types of sleep we could be talking about. I'm assuming you're
talking about OS sleep i.e. when the screen goes black. However, there is also
the "disk spindown while the rest of the machine continues running and the
screen stays on". I'm assuming it's not the latter because that would be a Mac
OS X bug and would trash just about every app on the OS :-)


(You're wrong - I did look for other bugs, yes it did occur to me etc. I spent
quite a while searching for combinations of words that might match.
Unfortunately "disk sleep" wasn't in my combinations.)
Assignee: location-bar → sfraser

Comment 8

13 years ago
can you reproduce this bug with a current nightly build?

with the fix from bug 232715 now landed, i wonder if it fixed the issues you 
mention in this bug.
(Reporter)

Comment 9

13 years ago
I've tried, and haven't seen it, on yesterday's nightly build:

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a5) Gecko/20041002


I've done a user-forced sleep from Apple menu (kIOMessageSystemWillSleep), and a
sleep in which I let the machine go to sleep after a timeout
(kIOMessageCanSystemSleep), which I presume recreates the two scenarios
described in bug #232715.

Neither of these two has resulted in any observable bugs.

WELL DONE ALL!! :-)

Comment 10

13 years ago
-> WFM per comment 9.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.