OS X disk images should include an installation background like Seamonkey

RESOLVED WORKSFORME

Status

()

Firefox
Installer
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Scott MacGregor, Unassigned)

Tracking

({helpwanted})

unspecified
PowerPC
Mac OS X
helpwanted
Points:
---
Dependency tree / graph
Bug Flags:
blocking-aviary1.0 -
blocking-aviary1.5 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments, 1 obsolete attachment)

(Reporter)

Description

14 years ago
Filing for Jason Kersey who has run into this issue as he evangalizes Firefox
and Thunderbird at his company. 

Currently, you cannot run Firefox or Thunderbird from the disk image because of
how the extension manager works (I think). If you try, you get stuck in the
famous infinite process loop on the mac.

I understand the technical reasons why that happens, but our users won't. Maybe
we can help alleviate the problem by making the OS X package look more like the
seamonkey one.

The disk image for the suite has a big mozilla logo and text that says "To
install, simply drag the Mozilla image to the location of your choice."

I bet it would help reduce the # of folks that run into this if we do something
similar. 

Ben/Brian, know of any good OS X folks that might want to do this? The code most
already exist in seamonkey somewhere (Javier?)
(Reporter)

Comment 1

14 years ago
nominating as a mac 1.0 blocker
Flags: blocking-aviary1.0mac?
(Reporter)

Comment 2

14 years ago
Created attachment 157761 [details]
screen shot of the seamonkey disk image
Created attachment 162211 [details]
Background image for Firefox installation window

The Seamonkey image is stored in
mozilla/build/package/mac_osx/mozilla-background.jpg
Attachment #162211 - Flags: review?(mscott)
(Reporter)

Comment 4

14 years ago
the image looks good to me but where does it go and how does it get incorporated
into the mac package? 

You'll need approval from Ben and the visual identity team on the icon as well.
There is a shell script in mozilla/build/package/mac_osx called make-diskimage.
The command line options are commented inside the script. If you call that you
can build an image including your background image, icon position, etc. 

However, I have yet to have it work for me, producing a Firefox disk image
without a toolbar/sidebar, with the background image, and with the icon sized
and placed properly. 

The problem lies in the .DS_Store file which holds all this information. Maybe
some comments from the folks who set this up for Mozilla would help reproduce it
for Firefox.
Comment on attachment 162211 [details]
Background image for Firefox installation window

sorry for bugspam
Attachment #162211 - Flags: review?(mscott)
Created attachment 162301 [details]
better background img for Firefox installer

better background image -- having the text in the middle left no good space for
the icon
Attachment #162211 - Attachment is obsolete: true
Summary: OS X package should include an installation background like Seamonkey → OS X disk images should include an installation background like Seamonkey
Created attachment 163715 [details] [diff] [review]
Patch to build/package/mac_osx/make-diskimage

This made the make-diskimage script work for me. We used to show the MPL when
mounting the image, this patch restores that but I'm not sure if that's what we
want (there's been talk about an EULA). I do have a better styled MPL if we do
go with the MPL.

Comment 9

14 years ago
This is important.  Most people do not read the release notes, and would not
know what to do with the disk image.  It seems that many, if not most people
(such as my former computer science teacher, who has been using Macs for at
least ten years) assume that it is an installer, and try to run it from the disk
image.  This is something that both Seamonkey and Camino have, and that sounds
fairly easy and safe to implement.  Many bugs that were nominated to block
1.0mac (or that actually were blocking it) have been completely passed over now
that it is coming out at the same time, including many major Mac-specific
usability issues (especially in regard to the menubar with no window open).  It
would be nice if this was NOT one of the bugs that gets passed over, especially
since it will cause people to have trouble actually installing Firefox.

Nominating to block aviary-1.0, noting that it already has been nominated to
block 1.0mac.
Flags: blocking-aviary1.0?
Created attachment 165088 [details]
.DS_Store file to make Firefox window with background image (jpg)

I was able to make a .dmg using the patched make-diskimage script, using this
.DS_Store file.

Be sure to use the attached .jpg background image, as I couldn't make it work
with the .png
Created attachment 165089 [details]
Background image for Firefox installation window - jpeg version
For Seamonkey, the make-diskimage script looks to be called from
mozilla/xpinstall/packager/Makefile.in

I'm not sure how Firefox's .dmg is built, but given the above Makefile, as well
as the dsstore file I finally got to work last night, this probably could be
added soon.
1.0 is done.
Flags: blocking-aviary1.0? → blocking-aviary1.0-

Updated

14 years ago
Flags: blocking-aviary1.0mac?

Updated

14 years ago
Flags: blocking-aviary1.1?
Flags: blocking-aviary1.1? → blocking-aviary1.1-

Comment 14

13 years ago
Any progress on this?

Would be nice to have this for 1.1...
Keywords: helpwanted

Comment 15

13 years ago
*** Bug 301457 has been marked as a duplicate of this bug. ***

Comment 16

13 years ago
I can do this for 1.5 if there's interest.
Mark, it would be nice to have. So yes, please do.

Comment 18

13 years ago
There will be a nontrivial localization impact, unless you decide you want each
locale to get en-US license agreements and "drag the icon to your disk" text. 
I'll have an English-only patch first, and then you can decide where to head
with localizations.

On top of that, there are branding considerations here.  What I'm working on now
will allow a different license and background for DeerPark and Firefox.

Updated

13 years ago
Depends on: 302080
Comment on attachment 162301 [details]
better background img for Firefox installer

Kevin, what do you think?
Attachment #162301 - Flags: review?(kevin)

Comment 20

13 years ago
Most likely going with the images in bug 283598.

Updated

13 years ago
Assignee: mark → nobody
QA Contact: bugzilla → installer

Comment 21

13 years ago
WORKSFORME sounds good here.  This is fixed on the trunk and branch under bug
302080.  The artwork comes from bug 283598, and will be replaced with new
artwork under that bug.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.