Tab key functionality not working properly

RESOLVED WORKSFORME

Status

Calendar
Sunbird Only
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: Anupama, Assigned: Mostafa Hosseini)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)
Build Identifier: Sunbird2.0

TAB KEY FUNCTIONALITIY NOT WORKING PROPERLY

Reproducible: Always
Steps to Reproduce:
1 CLICK MENUBAR>>TOOLS>>OPTIONS
2 SELECT A PARTICULAR OPTION EG GENERAL,VIEW ETC USING A TAB KEY.
3 PRESS THE TAB KEY ON EACH EVERY FIELD IN GENERALS OPTION.


Actual Results:  
THE TAB ORDER IS NOT PROPER

Expected Results:  
1 OPTIONS WINDOW DISPLAYED.
2 GENERALS TAB DISPLAYED.
3 THE TAB KEY DOESNOT GO TO THE CATEGIRY LIST i.e WE CANT SELCT CATEGORY BY THE
TAB KEY.
(Reporter)

Comment 1

13 years ago
NOTE
	
  IF WE HAVE ALREADY SELECTED HE ITEM IN THE CATEGORY LIST AND THEN TRY TAB KEY
IT DOES RESPONSE.
  IT HAPPENS FOR FIRST OCCURRENCE AFTER OPENING THE WINDOW.

Updated

13 years ago
Summary: TAB KEY FUNCTIONALITIY NOT WORKING PROPERLY → Tab key functionality not working properly

Comment 2

13 years ago
Clarification: The tab order is proper, however, the first category is not
automatically selected when the tab reaches that field.  Using the arrow keys at
this point confirms that the tab is working properly though.  (Suggest that this
bug severity be set to 'trivial'.  Will confirm after that happens.)

Comment 3

13 years ago
I thought about this some more and realized that the current behavior is correct, since otherwise 
tabbing through the list would require a user to select a category for the event, which is otherwise 
optional.  Since it is possible to tab through to the category list, and then use the down arrows to select 
a category, resolving wfm.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
The bugspam monkeys have been set free and are feeding on Calendar :: Sunbird Only. Be afraid for your sanity!
QA Contact: gurganbl → sunbird
You need to log in before you can comment on or make changes to this bug.