Blank page when starting up ChatZilla

VERIFIED WORKSFORME

Status

Other Applications
ChatZilla
--
critical
VERIFIED WORKSFORME
14 years ago
11 years ago

People

(Reporter: Daniel Bachran, Assigned: Robert Ginda)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040830 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040830 Firefox/0.9.1+

CZ has problems starting up, if it is being run as the first Firefox instance.
It starts up properly if being run from within a running Firefox instance,
though. There is also a manual workaround to make CZ start up properly, see below.

Reproducible: Always
Steps to Reproduce:
1. have no instance of firefox running
2. execute "firefox -chat"

Actual Results:  
The CZ window opened, showing just a blank window frame (no menu, etc.) with the
basic layout (you could make out the userlist and the actual contents pane, but
nothing was in there -- all was completely blank) and with the throbber at the
bottom right moving.
No connection to the specified default IRC network is being established.

Expected Results:  
Open the CZ window with all contents (menu, userlist, content pages, tab strips,
input box, throbber) and connect to the specified default IRC network.

When starting CZ from within a running Firefox instance (via Tools -> Chatzilla)
it opens up fine.

I noticed that I can make CZ startup properly without any running firefox
instance if I manually remove the file XUL.mfl.

NOTE: I marked this bug as being critical, since it prevents "normal users" from
running CZ. BUT, this of course would also imply that "normal users" are running
Firefox nightlies, so you may disagree and change the severity.
(Reporter)

Comment 1

14 years ago
Ah, right. Too early in the morning... *sigh*

I'm running Chatzilla 0.9.64e.

Comment 2

14 years ago
ChatZilla 0.9.64e came fitted with a startup error dialog, should anything go
wrong during initialising. You don't mention this, so I can only assume it's not
getting to the point of running any of the JavaScript.

It works fine for me on "Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
Gecko/20040828 Firefox/0.9.1+" though.

If removing the XUL.mfl file makes it work, it's hard to see it's a CZ bug at all.

Comment 3

14 years ago
Actually, I seem to remember something similar happening when they screwed up
the compilation of RegExps in JS... I just can't find the bug.
(Reporter)

Comment 4

14 years ago
After testing this with a post-10PR version of Firefox, this doesn't seem to be
an issue anymore.

User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3)
Gecko/20040923 Firefox/0.10

Chatzilla 0.9.65
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Core → Other Applications
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.