All users were logged out of Bugzilla on October 13th, 2018

View Selection Source 'Dom Source' window has 'Save Page As' greyed out

RESOLVED DUPLICATE of bug 235067

Status

--
minor
RESOLVED DUPLICATE of bug 235067
14 years ago
14 years ago

People

(Reporter: sparr0, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a3) Gecko/20040808 MultiZilla/1.6.4.0b
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a3) Gecko/20040808 MultiZilla/1.6.4.0b

when viewing the dom source of a selection the file menu has a 'save page as'
entry but it is greyed out.  this forces me to select all in the dom source
window, paste into a text editor, and then save from there, unneccessarily annoying.

Reproducible: Always
Steps to Reproduce:
1. select something
2. view selection source
3. try to file|savepageas

Actual Results:  
entry greyed out

Expected Results:  
let me save

Comment 1

14 years ago
I think this is intentional, since you would exspect that it saves the DOM
Source only. But the Save Dialog can't do that atm. Also see the source for this:
 // disable menu items that don't work since the selection is munged and
 // the editor doesn't work for MathML
 document.getElementById('cmd_savePage').setAttribute('disabled', 'true');
 document.getElementById('cmd_editPage').setAttribute('disabled', 'true');

The only possibility would be to create some document out of DOM Source which
could then be saved.

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 235067 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.