If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mozilla crashes if I try to print certain html-documents containing images

RESOLVED DUPLICATE of bug 246226

Status

()

Core
Printing: Output
--
critical
RESOLVED DUPLICATE of bug 246226
13 years ago
13 years ago

People

(Reporter: Birgit Hubatka, Unassigned)

Tracking

({crash})

Trunk
x86
OS/2
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.7) Gecko/20040617
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.7) Gecko/20040617

HTML-documents which contain at least one transparent GIF within a table can be
displayed normally. But no matter if loaded in navigator or in composer pressing
the button "Print" causes Mozilla to crash.
I could reproduce the error with a new document containing only one table and in
one cell the suspicious image from solnet. Printing this document failed.
If I saved the GIF with PMVIEW its background was lo longer transparent. As soon
as I used this GIF instead of the original one, printing was no problem at all.

examples:
http://www.sbb.ch/Fahrplan (After results of query for a public transport
connection appear)
http://www.solnet.ch

Reproducible: Always
Steps to Reproduce:
1. load the document http://www.solnet.ch
2. Press the button "print"

Actual Results:  
Mozilla crashed

Expected Results:  
print the document

Comment 1

13 years ago
Can you post the trap screen? Do you print to a postscript printer?

Comment 2

13 years ago
Yes. please post full printer information and trap screen.

Updated

13 years ago
Severity: normal → critical
Keywords: crash
(Reporter)

Comment 3

13 years ago
So far, no trap screen appeared. Neither Mozilla nor OS/2 produces an error
message before or immediately after Mozilla dies.

Yes, it is a postscript printer (Xerox Phaser 8200B)

Comment 4

13 years ago
Have a look in POPUPLOG.OS2 on your bootdrive. It should contain the crash
information.
This is most likely a dupe of bug 246226.
(Reporter)

Comment 5

13 years ago
------------------------------------------------------------

09-06-2004  05:56:43  SYS3175  PID 0033  TID 0001  Slot 0074
C:\MOZILLA\MOZILLA.EXE
c0000005
1e85056c
P1=00000001  P2=192c5fa1  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=192dc2e7  EBX=192dc2e7  ECX=00000000  EDX=00000027
ESI=000000d2  EDI=192c5fa1  
DS=0053  DSACC=f0f3  DSLIM=ffffffff  
ES=0053  ESACC=f0f3  ESLIM=ffffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:1e85056c  CSACC=f0df  CSLIM=ffffffff
SS:ESP=0053:0012eb90  SSACC=f0f3  SSLIM=ffffffff
EBP=00000038  FLG=00012202

PMMERGE.DLL 0004:0002056c
(Reporter)

Comment 6

13 years ago
The trick wich the registry entry helps but unfortunately the the immage is sort
of printed inverted (not exactly, and therefore the image not only looks very
bad, but is unreadable if not incomprehensible).
OpenOffice (for which I had to install FontEngine) doesn't have any of the problems.

Comment 7

13 years ago
Definitely the same bug.

The transparency bug is here:

http://bugzilla.mozilla.org/show_bug.cgi?id=247902



*** This bug has been marked as a duplicate of 246226 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.