If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

link opens in wrong tab

VERIFIED WORKSFORME

Status

()

Firefox
Tabbed Browser
--
minor
VERIFIED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Jaap Eldering, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040823 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040823 Firefox/0.9.3

When clicking a link in one tab and immediately switching to another tab (before
the tab title changes to "loading...") the link opens in the newly selected tab,
instead of the tab where the link was clicked on.

Reproducible: Always
Steps to Reproduce:
1. open two different webpages in two tabs
2. click on a link in the first tab and immediately click on the second tab


Actual Results:  
new link opens in second tab

Expected Results:  
new link opens in first tab

I have no themes installed and as only extension the "Tabbrowser Preferences
0.6.7" by Bradley Chapman. I'm running firefox on a pentium3 450 MHz PC.

Comment 1

13 years ago
Please re-test with newer version of Firefox and without TBP.
(Reporter)

Comment 2

13 years ago
Now tested it with firefox 1.0 and without TBP.

I cannot reproduce the exact same bug (maybe fixed or page loads too fast to be
able to select another tab).

However when I (short, single) click on a link, I do sometimes get a different
mouse cursor, which seems to indicate that the link is selected for dropping
somewhere. When I click on a second tab immediately afterwards, it sometimes
opens in the second tab and sometimes in both the current and second.

Also I noticed that this drag-and-drop cursor appears when you click a link,
while moving the mouse. To me it seems that this behaviour should only be
selected when you keep the mouse button pressed.

Comment 3

13 years ago
WFM

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050405 Firefox/1.0+

Comment 4

13 years ago
Marking WFM by request of Joseph Felps and on observation of the comments.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.