uninstall of already uninstalled extension doesn't give correct feedback

RESOLVED DUPLICATE of bug 260704

Status

()

Toolkit
Add-ons Manager
RESOLVED DUPLICATE of bug 260704
14 years ago
10 years ago

People

(Reporter: asa, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
Uninstalling several extensions when you have enough extensions to overflow and
cause a scrollbar is painful.  After uninstalling the first extesion the focus
moves to the next. This is nice. The first problem arises when the focus shifts
to extensions that are out of view. The list doesn't scroll like it should.  The
second problem is that when you reach the end of the list, the selection moves
up one in the list and so if you're doing a "bulk uninstall" you might not
realize that you're back on one you already uninstalled. The EM offers to
uninstall it again which isn't correct. 

WHen we select an extension below the scrolled view, we should move the scroll.
When we reach the end of the extension list we should stop there or wrap back to
the top, not move back one in the list. When we attempt to uninstall an
extension that's already uninstalled, we should alert the user with "Extension
already set for Uninstall" or something like that.

Comment 1

14 years ago
duping to newer bug which has a patch

(the scroll issue should be a separate bug?)

*** This bug has been marked as a duplicate of 260704 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 2

14 years ago
Also see bug 245388.
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.