Browser contextual menu pops up in wrong location.

RESOLVED DUPLICATE of bug 257647

Status

()

defect
RESOLVED DUPLICATE of bug 257647
15 years ago
11 years ago

People

(Reporter: synthesis, Unassigned)

Tracking

Trunk
PowerPC
macOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a3) Gecko/20040831
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a3) Gecko/20040831

When in browser, contextual menu (ctrl-click inside browser window) pops up at
upper left corner of browser window, then pops back to cursor only once a
hierarchical menu item has been passed (but not clicked) by the cursor. If the
contextual menu contains no hierarchical menu item, then the menu does not pop
back to original ctrl-click location.

Reproducible: Always
Steps to Reproduce:
1. No special setup required: open Mozilla 1.8a3.
2. Ctrl-click in a browser window.
3. Contextual menu pops up in upper left corner of browser window.
4. Move cursor to that menu, and pass a heirarchical menu item.
5. Entire pop-up menu jumps back to where the original ctrl-click was performed.

Actual Results:  
6. Choosing a menu item in the pop-up works, both if it remains in the
upper-left corner (which it apparently does when it contains no heirarchical
menu item), and when it jumps back to the ctrl-click location (which it does if
a heirarchical menu item is passed over by the cursor).

Expected Results:  
The contextual menu should pop-up immediately adjacent to the ctrl-click
location in the browser.

Going back to Mozilla 1.8a2 eliminates the bug…
Please note your OS versions in bug 257647.

*** This bug has been marked as a duplicate of 257647 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

11 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.