Request to change -moz-border-radius to simply border-radius.

RESOLVED INVALID

Status

()

Core
CSS Parsing and Computation
--
enhancement
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: Matt, Assigned: dbaron)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040903 Firefox/1.0 PR (NOT FINAL) StumbleUpon/1.995
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040903 Firefox/1.0 PR (NOT FINAL) StumbleUpon/1.995

-moz-border-radius and border-radius (from the CSS3 spec) are the same CSS
attribute, so border-radius should become the way to parse it.
-moz-border-radisu could be left in for some time as a depcrecated version while
CSS stylists change their -moz-border-radii to border-radius.

Also, I request support for border-y-x-radius, as in border-top-left-radius for
the four seperate corners, all four being included in the CSS3 spec.

Reproducible: Always
Steps to Reproduce:
n/a
Actual Results:  
n/a

Expected Results:  
n/a

Comment 1

14 years ago
That never happens while the CSS3 draft is question is just a working draft, I
believe is the general practice.  It needs to at least reach Candidate
Recommendation status before you start discarding -moz prefixes.
Bill is correct.  Calling it "border-radius" before the specification in
question is in CR would be wrong.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
The reason for this is actually quite well demonstrated in this bug -- the 
currently proposed syntax for border-radius is actually NOT the same as the 
current syntax of -moz-border-radius.
You need to log in before you can comment on or make changes to this bug.