extension makes firefox fail to start (mixed case in chrome path)

RESOLVED DUPLICATE of bug 132183

Status

()

Toolkit
Add-ons Manager
--
major
RESOLVED DUPLICATE of bug 132183
13 years ago
9 years ago

People

(Reporter: ted, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

1.7 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

13 years ago
Someone on #firefox was trying to figure out why installing his extension was
making firefox fail to start.  Even in safe mode, with this extension installed,
Firefox refuses to start.

Possibly relevant lines from the log:
WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv)) failed, file nsChromeRegistry.cpp,
line 624
WARNING: chrome: failed to get base url for
chrome://vssdoclinks/content/vssDocLinksOverlay.xul -- using wacky default, file
nsChromeRegistry.cpp, line 534

I'll attach the whole console log and the offending xpi following this.
(Reporter)

Comment 1

13 years ago
Created attachment 157853 [details]
Console log for a failed startup
(Reporter)

Comment 2

13 years ago
Created attachment 157854 [details]
The offending extension

Warning: will probably screw your profile
(Reporter)

Comment 3

13 years ago
Created attachment 157855 [details]
Overlay from the extension

Seems to be choking on the overlay, but I could be wrong.
(Reporter)

Comment 4

13 years ago
Further testing from the user shows that the problem was his using mixed case
for the chrome path.  Changing it from vssDocLinks to vssdoclinks makes this
problem go away.

I would still like it if this didn't break Firefox to the point where safe mode
doesn't work.

Updated

13 years ago
Blocks: 248125

Updated

13 years ago
Summary: extension makes firefox fail to start → extension makes firefox fail to start (mixed case in chrome path)

Comment 5

13 years ago
The problem, as I understand, is the same as Mozilla bug 132183. Do you agree, Ted?

(at least when I made two testcases for this bug, they both failed on Mozilla too).
(Reporter)

Comment 6

13 years ago
Sounds about right.

*** This bug has been marked as a duplicate of 132183 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.