The text color on the start page is not set

VERIFIED FIXED

Status

www.mozilla.org
General
VERIFIED FIXED
14 years ago
6 years ago

People

(Reporter: Michal 'hramrach' Suchanek, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2) Gecko/20040903
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2) Gecko/20040903

This is the problem of web pages setting only some colors in style, leving the
rest at browser defaults. The page may render nicely in the web author's browser
but may be unreadable or ugly in other people's browsers.

Reproducible: Always
Steps to Reproduce:
1. start mozilla
2. set default colors so that text and link colors are light (ie white on black)
3. go to or reload the start page

Actual Results:  
The text on start page diappears or is barely visible.

Expected Results:  
The text color should not change because the background does not.

Updated

14 years ago
Summary: yhe text color on the start page is not set → The text color on the start page is not set

Comment 1

14 years ago
Suggested short-term fix:
Index: mozilla-org/html/css/cavendish/content.css
===================================================================
RCS file: /cvsroot/mozilla-org/html/css/cavendish/content.css,v
retrieving revision 1.3
diff -u -r1.3 content.css
--- mozilla-org/html/css/cavendish/content.css	2 Sep 2004 23:52:42 -0000	1.3
+++ mozilla-org/html/css/cavendish/content.css	7 Sep 2004 15:15:40 -0000
@@ -46,10 +46,12 @@
 
 	body {
 		background: #fff;
+                color: #000;
 	}
 
 	#mainContent, #side {
 		background: #fff;
+                color: #000;
 		line-height: 1.3; /* value other than 'normal' needed for WinIE */
 	}
 	.deepLevel #mainContent {
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

14 years ago
fantasai, this seems quite important. Can you check this in?
Checked in the fix.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Updated

14 years ago
Status: RESOLVED → VERIFIED
Product: mozilla.org → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.