Closed Bug 258126 Opened 19 years ago Closed 18 years ago

text-decoration drawn wrong on broken inline with side padding

Categories

(Core :: Layout: Block and Inline, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla1.8alpha4

People

(Reporter: dbaron, Assigned: dbaron)

References

()

Details

(Whiteboard: [patch])

Attachments

(2 files)

We don't call GetSkipSides, so 'text-decoration's are drawn incorrectly when an
inline with side padding is split over multiple lines.

Steps to reproduce:
 * load attached testcase

Expected results:
 * underline on first line ends even with the text

Actual results:
 * underline on first line ends a bit before the end of the text
Attached file testcase
Attached patch patchSplinter Review
Status: NEW → ASSIGNED
Priority: -- → P2
Whiteboard: [patch]
Target Milestone: --- → mozilla1.8alpha4
Attachment #157972 - Flags: superreview?(bzbarsky)
Attachment #157972 - Flags: review?(bzbarsky)
Comment on attachment 157972 [details] [diff] [review]
patch

r+sr=bzbarsky, but is there a good reason not to put the nsMarginSides thing in
nsMargin.h?

Also, does this pretty much address bug 238473?  The patch there seems to be
fairly similar...
Attachment #157972 - Flags: superreview?(bzbarsky)
Attachment #157972 - Flags: superreview+
Attachment #157972 - Flags: review?(bzbarsky)
Attachment #157972 - Flags: review+
I'm a little afraid of linking issues if I put this in nsMargin.h.
Fix checked in to trunk, 2004-10-25 16:48 -0700.
Status: ASSIGNED → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
Blocks: 238473
You need to log in before you can comment on or make changes to this bug.