Long table caption cause blank space to appear

REOPENED
Unassigned

Status

()

REOPENED
14 years ago
10 years ago

People

(Reporter: hh77, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.1) Gecko/20040707 MultiZilla/1.6.4.0b
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.1) Gecko/20040707 MultiZilla/1.6.4.0b

If a table caption is longer than the content in the table (the caption text
will be warpped), blank space will show up next to the table in composer -- but
NOT in the navigator.

If both width and height are specified in the style, then blank space will
appear in both navigator and composer.

Reproducible: Always
Steps to Reproduce:
Open the attached the test html file in both navigator and composer and compare.


Expected Results:  
The layout should be always as in the table 1 in the navigator.
(Reporter)

Comment 1

14 years ago
Created attachment 157974 [details]
the html/image/css to demo the problem
(Reporter)

Updated

14 years ago
Attachment #157974 - Attachment mime type: text/html → application/zip

Comment 2

14 years ago
Created attachment 157986 [details]
testcase from zip

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Mats, do you know the float code at all, by chance?

Comment 4

14 years ago
       caption 024F9114 r=0 a=3132,UC c=UC,UC cnt=893 
        text 024F9194 r=2 a=7032,UC c=UC,UC cnt=894  <<<<<< 
        text 024F9194 d=6480,228 
        br 024F9248 r=2 a=552,UC c=UC,UC cnt=895 
        br 024F9248 d=0,0 
       caption 024F9114 d=6480,240 
the block code overwrite the avail width under float conditions

Comment 5

14 years ago
aState.mAvailSpaceRect.width is 7032
while 
aState.mReflowState.availableWidth = 3132. 
(Reporter)

Comment 6

14 years ago
I used floatleft: .floatleft { float:left;  margin-right:10px; }

Maybe this is a behavior by design.  In that case, I would appreciate some
explanation on this.  It looks weird with caption wrapped and blank space on the
right.

Still some explanation needed to explain the difference b/w composer and navigator.

Further more, I found out that sometimes the behavor is random.  For example, I
set the image style to its local width 320 (not the test image included) and
leave out height, the layout is good.  However, change unrelated text, the
layout can be bad.  Once loaded and appears to be good or bad, reloading does
not change it.  You would need to alter some text to see if you get it to be
good again.

This behavior makes it sound like a programming bug -- just my guess.

Comment 7

10 years ago
Looks like the rewrite fixed this issue. Works for me Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b1pre) Gecko/20080901033305 Minefield/3.1b1pre
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
"the rewrite"?

This was fixed between 2005-10-16-07 and 2005-10-17-07, presumably by one of the image changes there.  At least that's what the testcase in the bug shows.

Given that, it's not obvious that the general issue is fixed.  Using a different kind of incremental reflow (instead of the image popping in), could well trigger it.  Someone should try constructing such a testcase that doesn't use an image and fails in the 2005-10-16-07 build.

In any case, bugs like this shouldn't be resolved without a regression test being added...
Status: RESOLVED → REOPENED
Flags: in-testsuite?
Resolution: WORKSFORME → ---
You need to log in before you can comment on or make changes to this bug.