tables not displaying images with in <td>

RESOLVED WORKSFORME

Status

()

Core
Layout: Tables
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Timothy Garland, Unassigned)

Tracking

Other Branch
All
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461; Roadrunner; SV1; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.8

The images are not displayed within the table segment.  The code passes the 
W3C HTML 4.0 transitional validation.  The code is from a php picture gallery 
script.  Code pasted below:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<title>Richard Brown Music :: Picture Gallery</title>
<link rel="shortcut icon" type="image/ico" href="images/brown.ico">
<link rel="STYLESHEET" href="includes_html/css/RichardBrownSwing.css" 
type="text/css">
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<META NAME="abstract" CONTENT="Richard Brown Music, great dance music for all 
occasions.">
<META NAME="robots" CONTENT="FOLLOW,INDEX">
<META NAME="author" CONTENT="Richard Brown Music">
<meta name="title" content="Richard Brown Music - Houston's premier source for 
live musical entertainment for your important events and galas.">
<meta name="keywords" content="Houston, music, Latin, dance, weddings, 
funerals, gala, orchestra, big band, rhythm and blues, singer, perform, string 
quartet, string ensemble, party music, live band, dance floor, vocals, 
percussion">

<script type="text/javascript" language="JavaScript">
function mmLoadMenus() {
  if (window.mm_menu_0727143836_0) return;
 

  
    window.mm_menu_0727143836_0 = new Menu("root",245,20,"Verdana, Arial, 
Helvetica, sans-
serif",12,"#000000","#000000","#ffffff","#FFD875","right","middle",6,0,500,-
5,3,true,true,true,-6,true,true);
  mm_menu_0727143836_0.addMenuItem
("Richard&nbsp;Brown&nbsp;Orchestra", "location='orchestra.html'");
  mm_menu_0727143836_0.addMenuItem
("Richard&nbsp;Brown&nbsp;Latin&nbsp;Orchestra", "location='latin.html'");
    mm_menu_0727143836_0.addMenuItem
("Richard&nbsp;Brown&nbsp;String&nbsp;Ensemble", "location='strings.html'");
    mm_menu_0727143836_0.addMenuItem
("Richard&nbsp;Brown&nbsp;Rhythm&nbsp;&amp;&nbsp;Blues&nbsp;Review", "location=
'randb.html'");

   mm_menu_0727143836_0.fontWeight="normal";
   mm_menu_0727143836_0.hideOnMouseOut=true;
   mm_menu_0727143836_0.bgColor='#000000';
   mm_menu_0727143836_0.menuBorder=1;
   mm_menu_0727143836_0.menuLiteBgColor='#000000';
   mm_menu_0727143836_0.menuBorderBgColor='#ffffff';

  window.mm_menu_0727144017_0 = new Menu("root",126,20,"Verdana, Arial, 
Helvetica, sans-
serif",12,"#000000","#000000","#ffffff","#FFD875","right","middle",6,0,500,-
5,3,true,true,true,-6,true,true);
  mm_menu_0727144017_0.addMenuItem("Upcoming 
Events", "location='events.html'");
  mm_menu_0727144017_0.addMenuItem("Biographies", "location='bio.html'");
   mm_menu_0727144017_0.addMenuItem
("Testimonials", "location='testimonial.html'");
   mm_menu_0727144017_0.addMenuItem("Home", "location='index.html'");
   mm_menu_0727144017_0.fontWeight="normal";
   mm_menu_0727144017_0.hideOnMouseOut=true;
   mm_menu_0727144017_0.bgColor='#000000';
   mm_menu_0727144017_0.menuBorder=1;
   mm_menu_0727144017_0.menuLiteBgColor='#000000';
   mm_menu_0727144017_0.menuBorderBgColor='#ffffff';

  window.mm_menu_0727144141_0 = new Menu("root",130,20,"Verdana, Arial, 
Helvetica, sans-
serif",12,"#000000","#000000","#ffffff","#FFD875","right","middle",6,0,500,-
5,3,true,true,true,-6,true,true);
  mm_menu_0727144141_0.addMenuItem("Song List","location='songlist.html'");
  mm_menu_0727144141_0.addMenuItem("Picture 
Gallery","location='gallery.html'");
   mm_menu_0727144141_0.addMenuItem("Video 
Gallery","location='vgallery.html'");
   mm_menu_0727144141_0.fontWeight="normal";
   mm_menu_0727144141_0.hideOnMouseOut=true;
   mm_menu_0727144141_0.bgColor='#000000';
   mm_menu_0727144141_0.menuBorder=1;
   mm_menu_0727144141_0.menuLiteBgColor='#000000';
   mm_menu_0727144141_0.menuBorderBgColor='#ffffff';

mm_menu_0727144141_0.writeMenus();
} // mmLoadMenus()
   <!-- 
        
        if (top.frames.length >1) 
{top.location="http://www.richardbrownmusic.com";}
        




-->


</script>
<script type="text/javascript" language="JavaScript" 
src="includes_html/javascript/mm_menu.js">

</script>
</head>
<body >
<script type="text/javascript" language="JavaScript1.2">
mmLoadMenus();
</script><!-- Image with table -->
<table border="0" cellpadding="0" cellspacing="0" align="left"width=680>
<tr>
<td width=40></td>
<td>
<table border="0" cellpadding="0" cellspacing="0" align="left" class="c1">
<tr><!-- row 1 -->
<td><img alt="image" src="images/shim.gif" width="1" height="34" 
border="0"></td>
</tr>

<tr><!-- row 2 -->
<td align="right"><span style='margin-bottom:0px;'><img alt="image" 
src="images/rbm_header.gif" border="0" align="right"></span></td>
</tr>

<tr>
<td class="maintext">
<table cellpadding="0" cellspacing="0" border="0" dir="ltr">
<tr>
<td colspan="12"><img alt="image" src="images/top_box.gif" border="0" 
width="640" height="10"></td>
</tr>

<tr>
<td class="c2"></td>
<td align="center" valign="middle" class="c3"><a href="about.html" 
class="rbm_menu" id="link3" onmouseover="MM_showMenu
(window.mm_menu_0727144017_0,-31,16,null,'link3')" onmouseout="MM_startTimeout
();">About RBM</a>
</td>
<td class="c4"></td>
<td align="center" valign="middle" class="c3"><a href="ensembles.html" 
class="rbm_menu" id="link2" onmouseover="MM_showMenu
(window.mm_menu_0727143836_0,-31,16,null,'link2')" onmouseout="MM_startTimeout
();">Ensembles</a>
</td>

<td class="c4"></td>
<td align="center" valign="middle" class="c5"><a href="multimedia.html" 
class="rbm_menu" id="link4" onmouseover="MM_showMenu
(window.mm_menu_0727144141_0,-33,16,null,'link4')" onmouseout="MM_startTimeout
();">Multimedia</a>
</td>
<td class="c4"></td>
<td align="center" valign="middle" class="c3"><a href="hire.html" 
class="rbm_menu">Hire</a>
</td>
<td class="c4"></td>
<td align="center" valign="middle" class="c3"><a href="contact.html" 
class="rbm_menu">Contact</a>
</td>
<td class="c2"></td>
</tr>

<tr>
<td colspan="11" class="c6"></td>

</tr>
</table><table cellpadding="0" cellspacing="0" width="640" style="margin-
bottom: 5px; margin-top: 10px; layout-flow: horizontal;">
<tr>
<td colspan="4">

<span class="c20">Richard Brown Music Picture Gallery</span><br>
<span class="c8">Thumbnail view :: to view the full-size images click on a 
thumbnail.<br>
There are currently 7 images in this gallery.</span>
<br><br>
</td>
</tr>
<tr>
<td height="115">
<a href="?gm=1&amp;gn=1">

<img alt="Richard Brown Orchestra string section"border="0" width="150" 
height="113" src="gallery_images/thumb/109-0949_img.jpg"></a>
</td>
<td height="115">
<a href="?gm=1&amp;gn=2">
<img alt="Singer singing"border="0" width="150" height="113" 
src="gallery_images/thumb/110-1083_img.jpg"></a>
</td>
<td height="115">
<a href="?gm=1&amp;gn=3">
<img alt="Richard Brown and his singers"border="0" width="150" height="113" 
src="gallery_images/thumb/110-1035_img.jpg"></a>
</td>
<td height="115">
<a href="?gm=1&amp;gn=4">
<img alt="the brass"border="0" width="150" height="113" 
src="gallery_images/thumb/110-1053_img.jpg"></a>
</td>
</tr><tr>
<td height="115">
<a href="?gm=1&amp;gn=5">

<img alt="latin singer"border="0" width="150" height="113" 
src="gallery_images/thumb/110-1023_img.jpg"></a>
</td>
<td height="115">
<a href="?gm=1&amp;gn=6">
<img alt="sax"border="0" width="150" height="113" 
src="gallery_images/thumb/112-1206_img.jpg"></a>
</td>
<td height="115">
<a href="?gm=1&amp;gn=7">
<img alt="Symphony Ball"border="0" width="150" height="113" 
src="gallery_images/thumb/rb_symball1.jpg"></a>
</td>
<td valign="top"></td></tr>
</table>
</div>
<div>
&nbsp;&nbsp;</div>



<img alt="image" src="images/bottom_box.gif" border="0" width="640" 
height="10"></td>
</tr>

<tr>
<td align="right"><strong class="footer">&copy; Richard Brown Music 
2004</strong></td>
</tr>
</table>
</td>
</tr>
</table>
</body>
</html>


Reproducible: Always
Steps to Reproduce:
1.
2.
3.



Expected Results:  
place images within <td>

Comment 1

14 years ago
Please attach a minimized testcase showing this bug
Summary: tables not displaying images with in <td> → tables not displaying images with in <td>

Comment 2

14 years ago
could you please link us to it? the problem is probably has to do with the way
you are linking to the images like '<img src="images/shim.gif">' try adding a
'/' in front of images/shim.gif and all the other images, just try one at first
though. I  think the way some setups are they require / if front of the
path...not sure though.

When i tried with the code you gave i got it to work.
http://www.music-shares.com/images/258139.jpg
(Reporter)

Comment 3

14 years ago
(In reply to comment #2)
> could you please link us to it? 

http://richardbrown.timothygarland.com

username: rbdrum
password: carwash

>the problem is probably has to do with the way
>you are linking to the images like '<img src="images/shim.gif">' try adding a
>'/' in front of images/shim.gif and all the other images, just try one at first
>though.

I tried that (it's from a script so one '/' is all of them anyway) and it just
meant that it couldn't find the images.  I get this display problem on my test
server at home (Win XP running Apache) and the jumpline server I've given you
the address of.  Thanks for your help.  

Comment 4

14 years ago
I checked all of the links and every page is fine, except with the picture
gallery page the "Richard Brown Music Picture Gallery
Thumbnail view :: to view the full-size images click on a thumbnail.
There are currently 24 images in this gallery. " is behind the pictures. But
other then that, everything is good.
(Reporter)

Comment 5

14 years ago
(In reply to comment #4)
> I checked all of the links and every page is fine, except with the picture
> gallery page the "Richard Brown Music Picture Gallery
> Thumbnail view :: to view the full-size images click on a thumbnail.
> There are currently 24 images in this gallery. " is behind the pictures. But
> other then that, everything is good.

Yep that's the problem, the images won't display in the table segments.  When I use the view tables 
option from the web dev toolbar the tables are in the right place, the images are not.  Sorry should have 
given you the full url, my mistake.

Comment 6

14 years ago
I encounterd the problem when I tried to display a map of Ann Arbor, MI from
Mapquest.  Right clicking on the image's (empty) area, I can select "View Image"
and it displays fine.

Here's the URL:

http://www.mapquest.com/maps/map.adp?country=US&countryid=US&addtohistory=&searchtab=address&searchtype=address&address=&city=ann+arbor&state=mi&zipcode=&search=++Search++

Updated

14 years ago
Assignee: firefox → nobody
Component: General → Layout: Tables
Product: Firefox → Browser
QA Contact: firefox.general → core.layout.tables
Version: unspecified → Other Branch

Comment 7

13 years ago
Timothy is this still an issue (or is it fixed with current trunk builds)
(Reporter)

Comment 8

13 years ago
(In reply to comment #7)
> Timothy is this still an issue (or is it fixed with current trunk builds)

It turned out to be a problem with the css I was using, but I've lost the notes
that I had on it....as it was not to do with the <td> tag, I'd say it's not an
issue any more.

Comment 9

13 years ago
marking as wfm based on reporter comment
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.