back button does not work for a php forum set up as a content frame

RESOLVED DUPLICATE of bug 182689

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED DUPLICATE of bug 182689
14 years ago
10 years ago

People

(Reporter: maranda rose, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

PHP forum is set up as a content frame.  Back button does not acknowledge any
pages other than the main page, and depending on navigation prior to using the
back button, does not always acknowledge the site at all. Whether you have
visited only the main page, or browsed around, clicking on the back button takes
you back to the last unrelated site. If you have gone from this site to another,
unrelated site, the back button takes you to the main forum page rather than the
last page viewd.  These problems do not occur with IE or Navigator 7.

Reproducible: Always
Steps to Reproduce:
1.  go to any site, ie yahoo.com
2.  go to http://forum.bellspalsy.ws
3.  click on the first forum, "Q & A Zone" (this is the only forum that does not
require registation)
4.  click on the back button - you will be returned to yahoo rather than to the
last page at the forum.bellspalsy.ws

alternate scenario:
1.  go to http://forum.bellspalsy.ws
2.  click on the first forum, "Q & A Zone"
3.  go to an unrelated site, ie yahoo.com
4.  click on the back button.  you will be taken back to forum.bellspalsy.ws,
but to the main page rather thean the last page viewed.
Actual Results:  
see step 4 for both scenarios

Expected Results:  
should take you back to the last page viewed at http://forum.bellspalsy.ws

I am rating this as 'normal', but it is serious to me as webmaster of this
site... I find it gets very awkward, and could lose members due to navigation
problems such as this.
(Reporter)

Comment 1

14 years ago
I changed the severity to 'major'.  Forum is essentially unusable without
back/forward function.
Severity: normal → major

Comment 2

14 years ago
The same erroneous behaviour applies to http://www.bild.de/ (German yellow press)
Surfing this site has no impact on the History (which you can see if you sort
the History "By Last Visited").
This is caused by the nested (recursive) frames.

*** This bug has been marked as a duplicate of 182689 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: History → Bookmarks & History
QA Contact: mozilla → bookmarks
You need to log in before you can comment on or make changes to this bug.