better RSS links to news items on www.mozilla.org

VERIFIED FIXED

Status

VERIFIED FIXED
14 years ago
6 years ago

People

(Reporter: myk, Assigned: philor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
Our current news infrastructure puts news stories in news.html and then
generates RSS items that point to the URL referenced by the news stories rather
than the stories themselves.  This means RSS readers get the link without its
context, and  it can sometimes mean duplicate links in the RSS file, which
violates both the RSS spec and the sensible practice of having unique references
to each story in an RSS file.

RSS items should point to the stories on news.html via unique URLs, either by
anchoring stories with a unique anchor or by some other means.
I'm pretty sure this is going to be server ops rather than webmaster because I think this stuff is all generated by our funky build scripts.  Anyone know how they work?
Assignee: mozilla.webmaster → nobody
Component: webmaster@mozilla.org → Server Operations Projects
QA Contact: danielwang → justin
Yeah, it's all in mozilla-org/tools/make-news.pl .
The next question, then, is how do we want it to behave?
Hardware: DEC → All
*** Bug 349376 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

12 years ago
"Differently." It isn't unusual for feed readers to treat new items with the same link as duplicates to be ignored ("he probably just fixed a typo"), so anyone depending on our feed for news of security updates to Firefox may well think that 1.5.0.2 is still the current release. Firefox's Live Bookmarks show five items all titled from the 1.5.0.2 item on the 1.8 branch, and show a single item titled from the 1.5.0.2 item on the trunk. To me, that feels less "normal" and more "security-critical."

Simplest thing that server-ops could do is reverse the current indexing, so that the oldest news item is #1 rather than the newest being #1 until another newest comes along, and make the feed link be news.html#n

Simplest thing that webmonkeys could do is just link to the release notes first in release announcements, since make-news.pl grabs the first of multiple links.

Best thing would be to put the news in a weblog that will handle creating unique URLs and archiving items and creating a valid feed, and parse the feed from it to create the front page include.

Comment 6

12 years ago
Should this really be a server operations project?  
(In reply to comment #6)
> Should this really be a server operations project?  

Probably not, we have enough to do, and the web devs have access to this to fix it.
Component: Server Operations Projects → www.mozilla.org
QA Contact: justin → www-mozilla-org
(Assignee)

Comment 8

12 years ago
Created attachment 253293 [details] [diff] [review]
Fix v.1

Okay, while I still think that a new WordPress blog or two or three, and a redirect from news.html to it, is the way to go, that I can't do, and this I can. In general, instead of streaming things through from the input to the output file, while stashing the newest 15 for the feed, this parses the whole input file (to count the number of items), writes the RSS file with links to news.html#p{number} (which will both work for the feed in Firefox, and also let people on the mozilla.org front page see the post, instead of shooting off to the first link blindly), then writes the HTML file. Specifically, and around the edges:

- remove output/news.txt, which looks like nine year old debug leftovers

- remove the random tabs-sometimes-to-start whitespace, since I wound up touching almost every single line anyway

- remove support for links in <SUMMARY>, which was never used, and would make the link disappear completely from the feed

- remove $firstlink since we'll be linking to the post, not to the first link in the post

- remove "eatp" which only worked with "<p> === <br><br>" not with "<p></p> == paragraph"

- replace uppercase presentational markup with the snazzy new lowercase semantic markup all the kids were raving about four years ago

- remove $frontpage/<!-- * --> hot-comment, which isn't used since only the first three things in the feed go on the front page, even non-hot-commented things go in the feed, and nobody has done a non-frontpage post or removed old hot-comments in more than two years

- strip blank lines, and lines that are only <!-- comments -->

- fix a few bits of broken and invalid markup and a broken date

My output/news.html says it's valid HTML, and my output/news.rdf says it's valid RSS (and it better be, since it's unescapable that changing the links will make most feedreaders think every item is new again, but doing that twice because I messed up the first change wouldn't be very acceptable).
Assignee: nobody → philringnalda
Status: NEW → ASSIGNED
Attachment #253293 - Flags: review?(reed)
(Assignee)

Comment 9

12 years ago
There's a sample of the RSS output at http://dev.philringnalda.com/rsstests/news.rdf since Fx is a little pissy about not previewing local RSS files.
Comment on attachment 253293 [details] [diff] [review]
Fix v.1

r=me, thanks!

It passed my live testing and Perl syntax checking, which is good enough for me.
Attachment #253293 - Flags: review?(reed) → review+
Checking in html/news.html;
/cvsroot/mozilla-org/html/news.html,v  <--  news.html
new revision: 1.603; previous revision: 1.602
done
Checking in html/template-press.html;
/cvsroot/mozilla-org/html/template-press.html,v  <--  template-press.html
new revision: 1.8; previous revision: 1.7
done
Checking in tools/make-news.pl;
/cvsroot/mozilla-org/tools/make-news.pl,v  <--  make-news.pl
new revision: 1.21; previous revision: 1.20
done
Checking in tools/munge.pl;
/cvsroot/mozilla-org/tools/munge.pl,v  <--  munge.pl
new revision: 1.39; previous revision: 1.38
done
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Updated

11 years ago
Status: RESOLVED → VERIFIED
Product: mozilla.org → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.