If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

curly brackets without related statement not identified

RESOLVED DUPLICATE of bug 258305

Status

Rhino
Core
--
major
RESOLVED DUPLICATE of bug 258305
13 years ago
13 years ago

People

(Reporter: Gilles Barnier, Assigned: Igor Bukanov)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705)
Build Identifier: 

When curly brackets are defined without any related statement, and within the   
block there is a function call that is defined latter on (see example below). 

Note that if the function is defined before it is called, the problem does not 
exist. 



Reproducible: Always
Steps to Reproduce:
1. Try to parse the following script:

<HTML>
<BODY>
<SCRIPT>
{
            f1(1,2);
            function f1(l,m)
            {
                        alert("adi");
            }
}
</SCRIPT>
</BODY>
</HTML>


2.
3.

Actual Results:  
The parsing fails.

Expected Results:  
This is a legal javascript. The parser should have parsed this block 
successfully.
(Assignee)

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 258305 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

13 years ago
Created attachment 160915 [details] [diff] [review]
Though you do not consider it as a bug, this is the fix that we made in order to make things work in our technology
You need to log in before you can comment on or make changes to this bug.