Canceling page load results in incorrect favicon displaying on the tab bar

RESOLVED DUPLICATE of bug 258461

Status

()

Firefox
Bookmarks & History
--
minor
RESOLVED DUPLICATE of bug 258461
14 years ago
12 years ago

People

(Reporter: Jon Henry, Assigned: vlad)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040907 Firefox/1.0 PR (NOT FINAL)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040907 Firefox/1.0 PR (NOT FINAL)

This appears to only affect the tab bar, not the location bar or anywhere else
favicons are displayed. It also looks like it *has* to be a link from the
personal toolbar, not a url you type in or even one from the normal bookmarks menu.

This isn't a huge deal, but it definitely makes tabbed browsing a little
confusing when you get a lot of tabs open and want to quickly ID them by the
favicon.

Reproducible: Always
Steps to Reproduce:
1. Have a page open and the tab bar visible.
2. Click a link on your personal toolbar that has a favicon associated with it.
3. Quickly press escape to cancel the page load.

Actual Results:  
The favicon displayed on the tab bar is the icon of the site you canceled
loading, not the current page's.

Expected Results:  
Revert to the favicon associated with the current site.
(Reporter)

Comment 1

14 years ago
Sorry, my net connection flaked out and this got submitted twice.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Updated

14 years ago
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 258461 ***
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.