checksetup fails with out-of-sync DBD::mysql modues - document fix and workaround

RESOLVED FIXED in Bugzilla 2.18

Status

()

Bugzilla
Documentation
--
minor
RESOLVED FIXED
14 years ago
6 years ago

People

(Reporter: Seth Fuller, Assigned: Shane H. W. Travis)

Tracking

unspecified
Bugzilla 2.18

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: Version 2.18rc2 

In order to allow checksetup.pl to create the bugs database tables, the bugs 
user in the mysql.users table must have the password field encrypted with the 
mysql old_password function. The checksetup.pl script doesn't understand the 
new style encryption that the mysql password() function uses. For example:
update user set password = old_password('bugs_password') where user = 'bugs';


Reproducible: Always
Steps to Reproduce:
1. Create the bugs user and set the password in the user table with the mysql 
password function
2. Update the $db_pass variable in localconfig
3. Run checksetup.pl

Actual Results:  
The DBD-mysql perl module reports an authentication error and suggests 
updating the mysql client.

Expected Results:  
The checksetup.pl script should run to completion and create the bugs database.
This has nothing to do with Bugzilla, actually.  It's a DBD::mysql thing.  Your
DBD::mysql module was compiled against an older version of MySQL.  Recompile
DBD::mysql against the current MySQL libraries and the error will go away.
Assignee: zach → documentation
Component: Installation & Upgrading → Documentation
OS: Windows XP → All
Hardware: PC → All
*** Bug 266599 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 3

14 years ago
Created attachment 173372 [details] [diff] [review]
Doc changes for 2.18 and tip

Added a section to the Troubleshooting appendix to cover this.

(Troubleshooting needs to be reorganized so that we don't end up with one huge
long list issues in the main ToC, but that's an issue for another bug.)

Of note when I looked at troubleshooting.xml (and not really appropriate to
this bug, I know) ... I know that this is a brand-new section, but the
indenting style of it is completely different from the one I've been trying to
use consistently throughout the docs. I thought that the style had been agreed
on, in which case this section should probably have adhered to it; if not, then
we NEED to agree on a style so that it can become/be made uniform throughout.

(I do also remember that troubleshooting.xml was one of Jake's first projects
after being away for a year, so maybe it was agreed on in his absence and he
wasn't used to it yet?)
(Assignee)

Updated

14 years ago
Assignee: documentation → travis
Status: UNCONFIRMED → ASSIGNED
Attachment #173372 - Flags: review?(documentation)
Comment on attachment 173372 [details] [diff] [review]
Doc changes for 2.18 and tip

The recommendations here should be swapped.
The problem *is* that they're using a DBD::mysql that was compiled against an
older version of MySQL than the one they're running.  That's a given by them
even getting the error message.
Recompiling DBD::mysql against their current MySQL libraries will fix it.
If they can't recompile it for some reason (like they're running Windows, or
want to keep using a packaged version or something), then the old_password()
trick on the server will let them work around it.
Attachment #173372 - Flags: review?(documentation) → review-
(Assignee)

Comment 5

14 years ago
Created attachment 173377 [details] [diff] [review]
Doc changes for 2.18 and tip, take 2

Paragraphs re-ordered, re-worded. Thanks for the feedback.
Attachment #173372 - Attachment is obsolete: true
Attachment #173377 - Flags: review?(documentation)
Comment on attachment 173377 [details] [diff] [review]
Doc changes for 2.18 and tip, take 2

Obtaining a newer version *may* make the error go away.  Depends on whether the
newer version was compiled against current MySQL libraries or not.

But close enough :)
Attachment #173377 - Flags: review?(documentation) → review+
(Assignee)

Comment 7

14 years ago
Changed 'will' to 'may'. Thanks.

2.18:
Checking in troubleshooting.xml;
/cvsroot/mozilla/webtools/bugzilla/docs/xml/troubleshooting.xml,v  <--  
troubleshooting.xml
new revision: 1.2.2.4; previous revision: 1.2.2.3
done


Tip:
Checking in troubleshooting.xml;
/cvsroot/mozilla/webtools/bugzilla/docs/xml/troubleshooting.xml,v  <--  
troubleshooting.xml
new revision: 1.5; previous revision: 1.4
done
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Summary: Need to use mysql old_password function for bugs user password in mysql 14.6 → checksetup fails with out-of-sync DBD::mysql modues - document fix and workaround
(Assignee)

Updated

14 years ago
Target Milestone: --- → Bugzilla 2.18
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.