Status

Calendar
Sunbird Only
RESOLVED INVALID
14 years ago
12 years ago

People

(Reporter: Anupama, Assigned: Mostafa Hosseini)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)
Build Identifier: sunbird0.2

Improper week Count 

Reproducible: Always
Steps to Reproduce:
1:click on jan 2002
2:click on week
3:click on > till u reach jan 2003

Actual Results:  

 At the start of year 2002 week 1 and 1-7 days
 At the end of year 2002 and At the end of year 2003 week 1(last day of 2002 is 
not counted while counting no of weks in year 2002 )


Expected Results:  
At the end of year it should show week 52 and 1/2 days which is 53th
 At the start of year it should show week 1st and 1-6 days

Comment 1

14 years ago
Thanks, but week numbers are ISO 8601 standard week numbers.
Weeks start on Monday.
Week 1 of any year is the week that contains the first Thursday in January.
Most years have 52 weeks, but years that start on a Thursday and leapyears that
start on a Wednesday or a Thursday have 53 weeks in the ISO 8601 week numbering.

I think this bug is invalid.
Summary: Improper week Count → Improper week Count

Comment 2

14 years ago
I confirm that this bug is invalid because the week number implemented in
calendar are ISO 8601 ones, and this implementation is correct. 
Implementation of other week number calculation methods (see i.e.
http://www.merlyn.demon.co.uk/weekinfo.htm) could be request as an RFE in
another bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
The bugspam monkeys have been set free and are feeding on Calendar :: Sunbird Only. Be afraid for your sanity!
QA Contact: gurganbl → sunbird
You need to log in before you can comment on or make changes to this bug.