zh-min-nan language tag requires x-western locale

RESOLVED FIXED

Status

()

RESOLVED FIXED
15 years ago
14 years ago

People

(Reporter: t.starling, Assigned: smontagu)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3.1) Gecko/20030425
Build Identifier: 

After lengthy campaigning to have the zh-min-nan language code used on Wikipedia
for the peh-oe-ji orthography, IANA tag registrant Kai-hsu Tai was disappointed
to find that it is displayed in Mozilla using the Simplified Chinese font, which
looks really ugly for a script based on the latin alphabet.

I was initially skeptical about the use of "zh-min-nan" to describe a script
which is only used by a minority of Min Nan speakers, but wider polling of the
Chinese and Taiwanese Wikipedians convinced me to change my mind. Although the
language tag registration form
(http://www.iana.org/assignments/lang-tags/zh-min-nan) does not explicitly
specify a latin-based orthography, all of the listed language references
describe the use of such a script.

Browsing the Mozilla source code on the web leads me to believe that this can be
rectified by adding the following line to
mozilla/intl/locale/src/langGroups.properties:

zh-min-nan=x-western

Reproducible: Always
Steps to Reproduce:
Go to http://zh-min-nan.wikipedia.org . Assuming nobody has implemented a CSS
hack since I submitted this, you should see a latin-based orthography written in
a monospace font. This indicates that the Simplified Chinese font settings are
being used.

Actual Results:  
http://www.ph.unimelb.edu.au/~tstarling/zh-min-nan.png is a particularly ugly
screenshot of the phenomenon

Expected Results:  
The default western font should be used.
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040813
Firefox/0.9.1+

Reporter - please, use some modern version for testing before reporting. Your
version of Mozilla Suite is more than 1,5 years old!

Comment 2

15 years ago
(In reply to comment #1)
> WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040813
> Firefox/0.9.1+
> 
> Reporter - please, use some modern version for testing before reporting. Your
> version of Mozilla Suite is more than 1,5 years old!

I can reproduce the problem with 
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

Comment 3

15 years ago
(In reply to comment #0)

> Go to http://zh-min-nan.wikipedia.org . Assuming nobody has implemented a CSS
> hack since I submitted this, you should see a latin-based orthography written in
> a monospace font.

I noticed the effect before a CSS hack was put in place.  As the base IANA tag
is script-independent, zh-min-nan should not be assumed to render optimally with
a non-Western font.

Mozilla/5.0 (Windows; U; Windows NT 5.1; zh-TW; rv:1.7) Gecko/20040626 Firefox/0.9.1
Linux only.
Confriming with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040904
Firefox/1.0 PR (NOT FINAL)
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: All → Linux

Comment 5

15 years ago
It's not Linux only. On Linux, this issue manifests itself in a very prominent
way, but the issue itself is present on all platforms. 
OS: Linux → All

Comment 6

15 years ago
Doesn't seem to be fixed in Firefox 1.0?

Comment 7

14 years ago
Using Firefox 1.0.4 with Gentium installed but still not able to view
http://zh-min-nan.wikipedia.org/  with Gentium properly.  Sigh....  When will
this be fixed?

Comment 8

14 years ago
(I wonder if there is a web-site-specific stylesheet workaround to this....)

Comment 9

14 years ago
I wonder if this easy bug will be fixed soon?
(Assignee)

Comment 10

14 years ago
Created attachment 197524 [details] [diff] [review]
Patch

Do we also need an entry in languageNames.properties?
Attachment #197524 - Flags: review?(jshin1987)
I doubt that adding a lang to the UI without addition to languageNames.properties
works.
(Assignee)

Comment 12

14 years ago
Adding zh-min-nan.accept = true to language.properties is not going to work without some other code changes so that it gets parsed correctly, so please ignore that part of the patch, which in any case is beyond the scope of the bug as reported.

Comment 13

14 years ago
Comment on attachment 197524 [details] [diff] [review]
Patch

r=jshin assuming that only the first chunk will go in because as Simon wrote, the second part wouldn't work without changing our locale-name parsing code.
Attachment #197524 - Flags: review?(jshin1987) → review+
(Assignee)

Comment 14

14 years ago
First hunk only checked in.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Updated

13 years ago
Blocks: 354446
You need to log in before you can comment on or make changes to this bug.