Empty Start menu program folder created even when "Create icons for Firefox / In my Start Menu Programs folder" option is off

VERIFIED DUPLICATE of bug 245392

Status

()

VERIFIED DUPLICATE of bug 245392
14 years ago
13 years ago

People

(Reporter: darin-mozilla, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040908 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040908 Firefox/0.10

On the last panel of the Firefox installer (titled "Set Up Shortcuts"), the user
has the option to create Firefox shortcut icons on the desktop, in the Start
menu Programs folder, and in the Quick Launch bar. By default, all of these are
turned on (even after I turned them off the -last- time I ran the installer, but
that's a whole 'nother issue). If I turn them all off, and in particular if I
turn off the option labeled "In my Start Menu Programs folder", an (empty)
Firefox folder is created in the Start Menu Programs folder anyway. Granted,
this folder is empty and thus no shortcut icons are created (as advertised), but
it's still an annoyance to have this empty folder created when there's no reason
for it. (And because I like to keep my system as uncluttered as possible, I end
up having to manually delete this folder each time after running the installer.)

Reproducible: Always
Steps to Reproduce:
0. Delete any Firefox folder currently residing in your Start menu Programs folder.
1. Run Firefox installer for Windows
2. Go through each of the installer panels
3. On the last panel, titled "Set Up Shortcuts", disable the option "In my Start
Menu Programs folder".
4. Select the Next button.
5. Allow installer to run.
6. Check the Start menu Programs folder. You'll see that an empty Firefox folder
has been created anyway.
Actual Results:  
An empty Firefox folder has been created in the Start menu Programs folder.

Expected Results:  
Not created -any- Firefox folder in the Start menu Programs folder. (If the
folder is going to be empty, there's no reason to create it, particularly since
I indicated that I did -not- want anything created in the Start menu Programs
folder.)

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 245392 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → installer
You need to log in before you can comment on or make changes to this bug.