Missing shortcut (New Message... CTRL + M)

VERIFIED FIXED in Firefox1.0

Status

Firefox Graveyard
Help Documentation
--
enhancement
VERIFIED FIXED
14 years ago
2 years ago

People

(Reporter: JasnaPaka, Assigned: Jeff Walden (gone starting June 8))

Tracking

({fixed-aviary1.0})

unspecified
Firefox1.0
fixed-aviary1.0

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; cs-CZ; rv:1.8a2) Gecko/20040714
Build Identifier: Mozilla/5.0 (Windows; U; Win98; cs-CZ; rv:1.8a2) Gecko/20040714

There is a list of shortcuts in Firefox Help but in this list isn't "New Message
- CTRL + M". This shortcut is Windows only. 

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Created attachment 158354 [details] [diff] [review]
Add shortcut
Assignee: jwalden+fxhelp → jwalden+bmo
Status: UNCONFIRMED → ASSIGNED
(Assignee)

Updated

14 years ago
Assignee: jwalden+bmo → jwalden+fxhelp
Status: ASSIGNED → UNCONFIRMED
(Assignee)

Comment 2

14 years ago
Created attachment 158356 [details] [diff] [review]
Uses the real Opera shortcut per opera.com/support/tutorials/nomouse
Attachment #158354 - Attachment is obsolete: true
(Assignee)

Comment 3

14 years ago
Comment on attachment 158356 [details] [diff] [review]
Uses the real Opera shortcut per opera.com/support/tutorials/nomouse

Now that I'm supposedly the owner of Help, I don't think I need to get this
reviewed (I don't know for sure if that's true or not), but it still wouldn't
hurt.  Steffen?

My CVS tree account is working now, so I can check this in.
Attachment #158356 - Flags: review?(steffen.wilberg)

Comment 4

14 years ago
> Now that I'm supposedly the owner of Help
I may have missed something because my inbox blocked emails between 09/05 and
09/09, but according to Despot you're not the owner of the Help Systems Module.
That used to be R.J., who stepped back and is now a peer. In other words, we
don't have an owner right now.

But you are the default owner of all the bugs, which is a different thing, and
makes a lot of sense since you're fixing most of them :)

> My CVS tree account is working now, so I can check this in.
This is even better!

I think we should seek reviews on all changes except typos and other incidents
of obvious wrongness. Approval-aviary is not needed for Help content.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

14 years ago
Comment on attachment 158356 [details] [diff] [review]
Uses the real Opera shortcut per opera.com/support/tutorials/nomouse

Coming to the patch, Ctrl+M doesn't work in IE6 on WinXP SP2. There's no
shortcut in the respective menu either, so remove it and r=me.
Attachment #158356 - Flags: review?(steffen.wilberg) → review+
(Assignee)

Comment 6

14 years ago
(In reply to comment #4)
> > Now that I'm supposedly the owner of Help
> I may have missed something because my inbox blocked emails between 09/05 and
> 09/09, but according to Despot you're not the owner of the Help Systems
> Module.
> That used to be R.J., who stepped back and is now a peer. In other words, we
> don't have an owner right now.
> 
> But you are the default owner of all the bugs, which is a different thing, and
> makes a lot of sense since you're fixing most of them :)

...or maybe it's (eventually) the same thing.  I think the transition's being
done in bug 257258 (to which I was cc'd back when it was filed, and which I
doubt you'd get without manually adding yourself).

> I think we should seek reviews on all changes except typos and other incidents
> of obvious wrongness. Approval-aviary is not needed for Help content.

There's always an exception (like, say, optimizing image file sizes -- there are
always exceptions), but this makes sense.

Comment 7

14 years ago
(In reply to comment #4)
> > Now that I'm supposedly the owner of Help
> I may have missed something because my inbox blocked emails between 09/05 and
> 09/09, but according to Despot you're not the owner of the Help Systems Module.
> That used to be R.J., who stepped back and is now a peer. In other words, we
> don't have an owner right now.
> 
> But you are the default owner of all the bugs, which is a different thing, and
> makes a lot of sense since you're fixing most of them :)
> 

Jeff Walden is in control of Firefox Help. Remember that a peer deserves the
same respect as a Owner. When I left, I intended to establish a system where
Firefox and Seamonkey help would be treated as sub-modules. Jeff controls
Firefox, Neil controls Seamonkey.

If jeff wants a policy changed, then let it be changed. The current policy is
that you need r= for Help documentation EXCEPT when you're a peer. Jeff is a
peer so he can checkin with no approval. XUL/JS is another story. You need the
normal r=.

> > My CVS tree account is working now, so I can check this in.
> This is even better!
> 
> I think we should seek reviews on all changes except typos and other incidents
> of obvious wrongness. Approval-aviary is not needed for Help content.

Jeff doesn't have to if he doesn't want to. Its in his hands. Now if you want to
change the Help XUL review policy, you need to talk to ben.
(Assignee)

Comment 8

14 years ago
(In reply to comment #5)
> (From update of attachment 158356 [details] [diff] [review])
> Coming to the patch, Ctrl+M doesn't work in IE6 on WinXP SP2. There's no
> shortcut in the respective menu either, so remove it and r=me.

I'll probably get this in (if it's allowed in aviary via late-l10n -- which is
debatable) at the same time as the patch for bug 258684.
Status: NEW → ASSIGNED

Comment 9

14 years ago
(In reply to comment #7)
> Jeff Walden is in control of Firefox Help.
Okay.

> Remember that a peer deserves the same respect as a Owner.
I didn't mean to be disrespectfull. At all. Jeff is doing a great job. I was
just trying to interpret what bugzilla and despot told me. Despot didn't list
Jeff as a peer at the time I wrote comment 4 IIRC. And I got no email from R.J.,
although that may be my own fault (see comment 4).

> When I left, I intended to establish a system where
> Firefox and Seamonkey help would be treated as sub-modules. Jeff controls
> Firefox, Neil controls Seamonkey.
I see. And that's perfectly fine with me.

>> I think we should seek reviews on all changes except typos and other
>> incidents of obvious wrongness.
> Jeff doesn't have to if he doesn't want to. Its in his hands.
Jeff has already agreed that we're going to seek reviews from each other on most
changes, except typos, obvious mistakes, optimizing image file sizes and similar
exceptions. Even if we don't have to, I strongly suggest to seek reviews as a
matter of quality control.

I guess I shouldn't have made comment 4 without talking to R.J. first. And sorry
for abusing the bug with this discussion.
(Assignee)

Comment 10

14 years ago
Fixed branch and trunk.  One down, ~5 to go on my current list of stuff to whack
before it's hands-off time on the branch...
Blocks: 253104
Severity: normal → enhancement
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Keywords: fixed-aviary1.0
Resolution: --- → FIXED
Target Milestone: --- → Firefox1.0

Updated

13 years ago
Status: RESOLVED → VERIFIED
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.