JSS cannot be built with JDK 1.5 due to new keywords

RESOLVED FIXED

Status

JSS
Library
RESOLVED FIXED
14 years ago
12 years ago

People

(Reporter: glen beasley, Assigned: glen beasley)

Tracking

Details

Attachments

(1 attachment)

(Assignee)

Description

14 years ago
jdk 1.5 has made the following 

./org/mozilla/jss/ssl/SSLSocket.java:693: as of release 1.5, 'enum' is a
keyword, and may not be used as an identifier
(Assignee)

Comment 1

14 years ago
Created attachment 159514 [details] [diff] [review]
changed spelling of "enum" to _enum

The only changed required to build with JDK 1.5 is to change "enum" to _enum in
SSLSocket.java and SSLTest.java.
(Assignee)

Updated

14 years ago
Attachment #159514 - Flags: superreview?(wchang0222)
Attachment #159514 - Flags: review?(saul.edwards.bugs)

Comment 2

14 years ago
Comment on attachment 159514 [details] [diff] [review]
changed spelling of "enum" to _enum

r=wtc.
Attachment #159514 - Flags: superreview?(wchang0222) → superreview+

Updated

14 years ago
Attachment #159514 - Flags: review?(saul.edwards.bugs) → review+
(Assignee)

Comment 3

14 years ago
 cvs commit -m "258666 JDK 1.5 made enum a keyword"
cvs commit: Examining .
Enter passphrase for key '/home/gb134726/.ssh/id_dsa': 
Checking in SSLSocket.java;
/cvsroot/mozilla/security/jss/org/mozilla/jss/ssl/SSLSocket.java,v  <-- 
SSLSocket.java
new revision: 1.18; previous revision: 1.17
done
Checking in SSLTest.java;
/cvsroot/mozilla/security/jss/org/mozilla/jss/ssl/SSLTest.java,v  <--  SSLTest.java
new revision: 1.3; previous revision: 1.2
done
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.