If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Find in page should scroll down a bit further

VERIFIED DUPLICATE of bug 78833

Status

SeaMonkey
UI Design
--
enhancement
VERIFIED DUPLICATE of bug 78833
13 years ago
12 years ago

People

(Reporter: Sönke Tesch, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7) Gecko/20040803 Firefox/0.9.3

Find in page only scrolls the page as far as it needs to display the match in
the last line of the browser's content area. From time to time, it's handy to
see what's in the next four or five lines.

Imagine a threaded Web forum where you searched for your name to see if there
are any replies to your posting. Currently it will look like this after
searching for "Me":

[..]
Bla by John
  Re: Bla by Me
----------------------------

You have to scroll down manually each time to see if there is a reply to "Me":

[..]
Bla by John
  Re: Bla by Me
    Re: Bla by John

----------------------------

This would not be needed if Find in page scrolls down a few lines more by itself.

This is just the most obvious example, but I think it might be as useful to see
e.g. some more lines of paragraph where a match was found or the first few lines
of contents of a chapter if a match was found in a heading.


Reproducible: Always
Steps to Reproduce:

*** This bug has been marked as a duplicate of 78833 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Core → Mozilla Application Suite
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.