css anchor class definitions are not applied to anchors within unsigned list elements

RESOLVED DUPLICATE of bug 10458

Status

()

--
minor
RESOLVED DUPLICATE of bug 10458
14 years ago
14 years ago

People

(Reporter: md, Unassigned)

Tracking

1.7 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

if you define an css class for formating anchor elements like

a{text-decoration:none;}

and have anchors within unsined lists like

<u><a href="http://someurl.com">sometext</A></u>

that css definition will not be applied though using "transional" and "loose"
dtds as follows

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.1 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">

The expected behaviour would be, that in the above example the string "sometext"
would not be shown underlined by the rendering engine. The actual behaviour is,
that the text appears underlined.

Reproducible: Always
Steps to Reproduce:
1. use a Document starting with <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.1
Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">

2. Define a css as a{text-decoration:none;}
3. use a anchor definition like 
<u><a href="http://someurl.com">sometext</A></u>

4. Display the webpage in a firefos browser tab.



Actual Results:  
See that the anchortest is rendered underlined

Expected Results:  
expected behaviour would be anchortext not be shown underlined by rendreing engine

Updated

14 years ago
Assignee: firefox → nobody
Component: General → Layout
Product: Firefox → Browser
QA Contact: firefox.general → core.layout
Version: unspecified → 1.7 Branch
The underline is on the <u>, not on the <a>.  And you can't turn off
text-decorations on a parent by styling a child element.  Marking duplicate of
an invalid bug; Mozilla's behavior here is correct.

*** This bug has been marked as a duplicate of 10458 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.