Filter change then Ctrl-A changes filter instead of selecting all filtered messages

RESOLVED DUPLICATE of bug 191801

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 191801
13 years ago
10 years ago

People

(Reporter: Tim Johnson, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a4) Gecko/20040911
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a4) Gecko/20040911

If you change the filter in the mail "View" field, then press ctrl-A, the filter
changes back to "All" then selects all of the messages. Thus, instead of
selecting all of the messages from the chosen filter, all messages are now
chosen. In the past (at least as late as moz-2004-05-14 build), the filter
selection was left unchanged after ctrl-A was pressed. 

Reproducible: Always
Steps to Reproduce:
1.From Mail window, select a filter for the "View" field.
2.Press ctrl-A to select all of the messages displayed for that filter.
3.

Actual Results:  
The messages which are filtered appear, but when ctrl-A is pressed, the "View"
field changes from the chosen filter to the "All" view, and all messages are
selected, not those which were selected by the chosen filter.

Expected Results:  
Changing the "View" to a filter shows the filtered messages. However, pressing
ctrl-A should not change the filter setting, and should simply select all of the
currently filtered messages.

Comment 1

13 years ago
I have also the same problem, Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a4)
Gecko/20040927. Previous bahvior was match better.
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail

Comment 2

12 years ago
I am seeing this in Thunderbird 1.5b1 on OS X.

Comment 3

12 years ago
Note that Edit->Select->All does the right thing (i.e. only selects all messages in the current view), but this menu item also claims Ctrl+A as its short-cut.

I first hit this when moving all the messages my SPAM view. At least I didn't just delete all the messages I'd just selected (i.e. my entire inbox), but it was close call!

Comment 4

12 years ago
*** Bug 262676 has been marked as a duplicate of this bug. ***

Comment 5

11 years ago
== thunderbird Bug 279001

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 191801
You need to log in before you can comment on or make changes to this bug.