Closed Bug 258891 Opened 15 years ago Closed 15 years ago

munderover for sums should render like munderover for integrals

Categories

(Core :: MathML, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: john.s.thomsen, Assigned: rbs)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a4) Gecko/20040910 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a4) Gecko/20040910 Firefox/0.9.1+

<munderover> for &sum;

should render like

<munderover> for &int;

Reproducible: Always
Steps to Reproduce:
1. Load testcase
Actual Results:  
<munderover> and <msubsup> for sums render identically.

Expected Results:  
<munderover> and <msubsup> should render differently - just like the analogue
case for integrals.

An XHTML + MathmML testcase is available soon.
Attachment #158579 - Attachment mime type: text/html → text/xml
It is due to different definitions of |movablelimits| in the Operator Dictionary
(located in the file mathfont.properties somewhere on your disk). movablelimits
is false for &Integral, but true for &Sum:

operator.\u222B.prefix = stretchy:vertical largeop:true lspace:0em rspace:0em #
&Integral;

operator.\u2211.prefix = stretchy:vertical largeop:true movablelimits:true
lspace:0em rspace:thinmathspace # &Sum;

Thus, you see what you see. Simply use <mo movablelimits="false">&Sum;</mo> to
get your preferrred rendering.

I am marking INVALID because most of the default settings in our Operator
Dictionary are what were recommended in the MathML spec. Please re-open if our
default setting for &Sum is in error with the spec.
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.