We need plugin listings and packages at update.mozilla.org (flash, java, acrobat, shockwave, realplayer, others?)

VERIFIED DUPLICATE of bug 247814

Status

Toolkit Graveyard
Plugin Finder Service
--
major
VERIFIED DUPLICATE of bug 247814
14 years ago
4 years ago

People

(Reporter: frederic conrotte, Assigned: myk)

Tracking

unspecified
Bug Flags:
blocking-aviary1.0PR -
blocking-aviary1.0 -

Details

(Whiteboard: u.m.o.)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040911 Firefox/0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040911 Firefox/0.10

when surfing on sites using Macromedia Flash, Firefox 1.0PR tells me "Click here
to download the plugin".

If click, i get "The following plugins are available : Flashplayer 7.0.16" but
when i click on "Next", Firefox 1.0PR tells me that "Flashplayer 7.0.16 :
Failed" without no more informations :-/

If I click on "manual install" I do not know how to install it.

On other sites, if i need the java or Realplayer plugin, it only tells me that
the "plugin is not available" !

Is there any way I can get more infos why this does not work ? bandwidth problem  ?



Reproducible: Always
Steps to Reproduce:
1. go on a web site using a Macromedia Flash plugin, Java or Realplayer plugin
2. try to install it by clicking on "click here to install the plugin"
 

Actual Results:  
automatic plugin installation failed

Expected Results:  
successfull install ! :-)

try with websites www.euronews.net => video, http://www.flashkit.com or
http://www.appletcollection.com/

Updated

14 years ago
Summary: [blocking-aviary1.0PR?] Plugin Finder Service broken → Plugin Finder Service broken
(Reporter)

Updated

14 years ago
Flags: blocking-aviary1.0PR+

Comment 1

14 years ago
You're not supposed to touch the -/+ blocking flags unless your a driver.  I'll
leave it at ?, though due to the nearness of PR it's likely to get minused.

For general triage, I haven't tested plugin finder so I have no idea how
good/broken it is.
Flags: blocking-aviary1.0PR+ → blocking-aviary1.0PR?

Comment 2

14 years ago
Frederic, thanks for reporting this and getting it on our radar. We appreciate
your help on this very important release. 

This is known. It depends on us having real flash packages on the server which
we don't and won't until we conclude the work with Macromedia to redistribute
their plugin (I believe).  The infrastructure is in place, and I believe working
as expected. We simply don't have the plugins sitting on the server yet. 

The reason you see the different behavior between the Flash and Java (and
others) plugins is that we have a "dummy" flash listing on our server and we
don't yet have that for Java or RealPlayer or Shockwave, etc. This is all server
side issues and I believe that the client is behaving as expected. 

We will hopefully have more of the actual plugins in place for the 1.0 release
candidates. Thanks again for taking the time to bring this to our attention.
Flags: blocking-aviary1.0PR? → blocking-aviary1.0PR-
(Reporter)

Comment 3

14 years ago
okay, and thanks to you for the clear and quick explanation, you are doing a
very great job !

Fred

Comment 4

14 years ago
Actually, I looked and it appears that we don't have a confirmed bug on file for
this. I'm absolutely sure it's on our list of things to do but it's possibly
being covered by the people who handle the relationships with licensing and
other companies. I'm going to confirm this report and let it act as the 1.0
blocker for this issue. 
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-aviary1.0+

Comment 5

14 years ago
*** Bug 258742 has been marked as a duplicate of this bug. ***

Comment 6

14 years ago
*** Bug 257148 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Summary: Plugin Finder Service broken → We need plugin listings and packages at update.mozilla.org (flash, java, acrobat, shockwave, realplayer, others?)

Updated

14 years ago
OS: Linux → All
Hardware: PC → All

Comment 7

14 years ago
*** Bug 258742 has been marked as a duplicate of this bug. ***
What's the actual bug here Asa? plugin finder worked fine for me...

Comment 9

14 years ago
-> jst
Assignee: firefox → jst

Updated

14 years ago
Component: General → Plugin Finder Service
QA Contact: firefox.general → firefox.plugin.finder

Comment 10

14 years ago
*** Bug 262847 has been marked as a duplicate of this bug. ***

Comment 11

14 years ago
While we wait for the plugins to be placed on u.m.o, it might be useful for
testing purposes to "activate" the dummy portion of the server, so users/testers
can better differentiate between a Firefox bug and an u.m.o server bug.

Would the web page's top menu then look like this:

__/ Mozilla \_/ Firefox \_/ Thunderbird \_/ *Plugins* \______/ Login \__

(notice that I think the "Login" tab should be slightly more displaced from the
other tabs! New bug, or can someone do this "on-the-fly"?)

or would the site be:

__/ Mozilla \_/ *Firefox* \_/ Thunderbird \______/ Login \__
Home | FAQ | Extensions | Themes | *Plugins*

and only be visible when the "Firefox" tab is selected?

Comment 12

14 years ago
> ------- Additional Comment #8 From Ben Goodger  2004-09-27 21:53 PDT  [reply]
>-------
>
>What's the actual bug here Asa? plugin finder worked fine for me...

is the bug documenting the fact that you can't go to u.m.o and find plugins and
install them?

looks to me like we have no navigation path to find plugins, you have to wait
until you have a puzzel piece...

not sure this bug needs to block release of the client, but it needs to be
addressed soon.

maybe wolf or myk or someone working on u.m.o can help on this one.
Assignee: jst → psychoticwolf
(Reporter)

Comment 13

14 years ago
I really think this will be solved BEFORE 1.0 Final. Otherwise you will lose
many people from installing Firefox just because of this :-(

Updated

14 years ago
Whiteboard: server side

Updated

14 years ago
Assignee: psychoticwolf → myk

Comment 14

14 years ago
myk is going to have a look at this.
*** Bug 263341 has been marked as a duplicate of this bug. ***
*** Bug 264417 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Whiteboard: server side → u.mo,

Comment 17

14 years ago
This would be nice to have, but we've got licensing and other issues that may
make it difficult. I'm setting to blocking minus because this can happen after
the release if need be.
Flags: blocking-aviary1.0+ → blocking-aviary1.0-
Whiteboard: u.mo, → u.m.o.
(Reporter)

Comment 18

14 years ago
Thanks for your answer, FF1.0 is out in 15 days now, do you got any news ?

Is there any chance this issue can be sorted out before 1.0 is out ?
(Assignee)

Comment 19

14 years ago
I'm working on a basic update.mozilla.org plugins page that should be ready in a
couple days.
Status: NEW → ASSIGNED

Updated

14 years ago
Blocks: 247814

Comment 20

14 years ago
Is this a dupe of bug 247814, which introduced
https://addons.update.mozilla.org/plugins/ ?
(Assignee)

Comment 21

14 years ago
Yes.

*** This bug has been marked as a duplicate of 247814 ***
No longer blocks: 247814
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.